23

Open Mission Control

Use any of these methods to open Mission Control:

....

  • In OS X El Capitan, drag a window to the top of the screen.

https://support.apple.com/en-us/HT204100

I'm using a window snapping/resizing app and this feature above, introduced in El Capitan, is being triggered instead. This when I snap a window to the center top of the screen.

Is there a way to turn this feature off?

  • 2
    Are You using Better Touch Tool for windows snapping? Because there's an option El Capitan: delay Mission Control on top edge. – Mateusz Szlosek Nov 4 '15 at 22:23
  • @MateuszSzlosek I'm using HyperDock though, I have have Better Touch Tool as well. I'm happy with the look and feel of that but, might give BTT a shot to see how it feels. – Natetronn Nov 5 '15 at 2:09
  • 3
    I also really really really hate this as a long time mac user. It wastes so much of my time. Adding this without an option to disable was really evil. – Michael Johnston Oct 25 '16 at 3:37
18

According to the Reddit thread, Is there any way to disable Mission Control coming up when I drag a window to the top of the screen?, the solution is:

System Preferences > Mission Control

Uncheck "Displays have separate Spaces" then log out and back in again.

It works, I had the same issue & now it's sorted.

  • 3
    This worked for me, but introduced another problem relating to use of iTerm2 in a secondary window... so I had to switch the separate Spaces back on again. Looking for a solution that would only disable the drag to top edge feature of Spaces... – Pirkka Esko Feb 22 '16 at 8:28
  • You should choose to reopen the last opened applications and return this page back and upvote this. :) – Itachi Dec 8 '16 at 3:57
  • 1
    This does not work for me. I sometimes get the expose behavior when dragging to the menu bar, sometimes I don't. I have my menu bar on an external display on my MacBook Pro. – Rick Dec 28 '16 at 5:46
  • 1
    This removes the top menu bar, which for me is a bad tradeoff. – Peter Ehrlich May 16 '17 at 17:25
  • 4
    Pirkka Esko, you hit the nail on the dot. You have to choose: either have spaces off so that you can have a separate display act like its own computer (bar on top, full screen, etc) or turn it off so that you can properly use resizing apps. Apple should fix this. – jobonki Aug 14 '17 at 22:31
3

Haven't found out how to disable just the window drag activation but you can turn it off entirely with:

Disable:

defaults write com.apple.dock mcx-expose-disabled -bool TRUE && killall Dock

Enable:

defaults delete com.apple.dock mcx-expose-disabled && killall Dock

source

  • A -1 without an explanation is a useless contribution to this forum. – rob Sep 13 '18 at 17:06
  • 1
    Note to other people trying this, this will disable the full screen apps manager entirely, meaning you cannot use ^up to open it or the pinch in gesture. – Alex Gittemeier May 15 at 22:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .