5

I have disabled system integrity protection on El Cap following this Ask Different question but it keeps coming back every time I reboot which is annoying. Is there an extra step I need to perform to stop SIP switching itself back on after reboot?

  • What exactly do you need to do that requires disabling system protection? There is probably a more secure method for accomplishing the same task. – William T Froggard Nov 4 '15 at 22:33
  • I'm a developer and I regularly make changes to system files and directories plus Parallels refuses to start unless I turn SIP off. – merelyuseful Nov 5 '15 at 14:24
  • Time to upgrade Parallels then, at least. And even as a developer, unless you are doing very specific things you should be able to work and develop without disabling SIP. – nohillside Dec 14 '15 at 7:38
1

There should be no extra step required - in fact, reading through the excellent article linked from that question, I found this…

Because SIP’s configuration is stored in NVRAM, SIP’s protection settings will apply to the entire machine and will persist even if the OS is reinstalled.

This would perhaps imply your NVRAM is not correctly holding data -
perhaps try a reset, Cmd ⌘ Opt ⌥ P R at the chimes & keep holding until you hear the chimes a second time.

Source : System Integrity Protection – Adding another layer to Apple’s security model

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .