4

Has anyone noticed this strange behavior of OS X El Capitan regarding forward delete? The usual keyboard shortcut for this on keyboards that have no distinct forward delete button is fn + delete, which works on my MacBook Pro 13'' Early 2015 as it should.

Additionally I have a forward delete when holding down shift and delete. This is so annoying because it happens very often while writing larger texts (especially in German where you have a lot of capital lettered words) or programming that this situation occurs.

Does anyone know a way to remap/deactivate forward delete?

  • 1
    I can't reproduce the described Shift-Delete behavior with El Capitan here. Do you have any kind of keyboard utility installed? Does it occur in all applications or only in one/some? – nohillside Nov 3 '15 at 14:35
  • 1
    Can't repro in TextEdit & 10.11.1 Fn/Backspace = forward delete; Backspace or Shift/Backspace = backwards delete, as expected. Text Wrangler, on the other hand does exhibit this behaviour, but as I never tested it before, idk whether that is new since El Capitan. – Tetsujin Nov 3 '15 at 14:41
  • Nope, not using Text Wrangler - but it is a nice to know. I also have no keyboard extension installed, nor any tools running in the background. This is very, very strange... – Martin Majewski Nov 3 '15 at 22:58
4

This is a change in behavior in the 10.11.2 beta, build 15C27e. Wether or not this is intentional or a mistake is unclear. But it is infuriating.

  • 2
    @Arc676 This is a perfectly valid answer – nohillside Nov 5 '15 at 15:29
  • This is the answer! Somehow I didn't take the point in time into account from when the issue has started. But it was clearly from the time on I installed the beta on my machine. It's interesting that this issue hasn't been noticed by many testers so far nor this new behavior is documented somewhere. Hope that Apple fixes it asap. It really makes writing and coding harder... – Martin Majewski Nov 5 '15 at 19:30
  • Link to related reddit post : reddit.com/r/OSXElCapitan/comments/3qmls9/… – fdnhkj Nov 11 '15 at 11:24
  • Sadly I cannot accept two answers as correct, but what @kevin9794 says is also a valid and pretty good solution (not only for my forward-delete problem). BUT: Since 10.11.2 Beta 3 (15C40a) the behavior has disappeared! Everything is back to normal!!! :-) – Martin Majewski Nov 12 '15 at 21:06
  • The bug has been fixed in 15C40A. – Thom McGrath Nov 13 '15 at 16:47
2

Assuming you only see this in Textwrangler: You can change it in Preferences:

enter image description here

  • 9 hours later OP mentions he isn't using TextWrangler – Arc676 Nov 4 '15 at 8:48
  • Even if the OP wasn't using it, I am glad this answer stuck! It just helped me... – user207924 Oct 26 '16 at 15:50
1

There's no official setting to change it afaik, but there is a workaround to basically overwrite the system's Shift+Delete and map it to be just Delete.

  1. Download, install and launch Karabiner.
  2. Go to the Misc & Uninstall tab, and click the Open private.xml button. A Finder window to a folder with a file named private.xml should open.
  3. Open the private.xml file and replace its contents with the following:

    <?xml version="1.0"?>
    <root>
      <item>
        <name>Shift+Delete to Backward Delete</name>
        <identifier>private.fixbackspace</identifier>
        <autogen>__KeyToKey__ KeyCode::DELETE, ModifierFlag::SHIFT_L, KeyCode::DELETE</autogen>
        <autogen>__KeyToKey__ KeyCode::DELETE, ModifierFlag::SHIFT_R, KeyCode::DELETE</autogen>
      </item>
    </root>
    
  4. Go back to the Change Key tab. There should be a checkbox named "Shift+Delete to Backward Delete" in the list box (If you don't see it, click the Reload XML on the upper right corner). Select it.

That should fix the issue. In my case doing this for some reason also changed the delay between tapping a key and the key press being repeated. That's just a slider in System Preferences > Keyboard.

Bonus: Send feedback to Apple through the Feedback Assistant, or the online bug reporting site, or just wherever, so hopefully they fix this nonsense or at least add the a setting to change it.

From the reddit thread linked to by fdnhkj.

  • Thank you very much for your informative post! Sadly I cannot accept two answers as correct solutions! But I up-voted this post! :-) However, since 10.11.2 beta 3 (15C40a) the problem disappeared again. – Martin Majewski Nov 12 '15 at 21:09
  • Ah good to know! Will update as soon as I get a chance – kevin9794 Nov 13 '15 at 5:58

You must log in to answer this question.

protected by Community Nov 5 '15 at 15:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .