1

I had GIMP installed via sudo port install gimp. This created the GIMP.app in /Applications/MacPorts/. I accidentally deleted it manually (or with AppCleaner, not sure), so every time Macports scans installed binaries, it warns

Warning: Error parsing file /Applications/MacPorts/GIMP.app/Contents/MacOS/GIMP: Error opening or reading file

This is also what happens when I try to install again. I uninstalled and cleaned the port, but installing again does not work; the .app is not created and the above warning shows. How do I fix it?

1

I am not quite sure, but after I purged the unused dependencies of gimp, the error went away.

0

MacPorts has a force option that allows you to continue, even in the case of errors.

I'd force-remove and then install it again.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • To force what? Without -f the install completes, it is just that nothing happens. – oarfish Nov 6 '15 at 7:50
  • I meant, force uninstall – John Keates Nov 6 '15 at 13:45
  • I tried, to no avail. – oarfish Nov 6 '15 at 15:53
  • So force removing and then installing it doesn't do anything? Whats in the macports log? – John Keates Nov 7 '15 at 13:16
  • I ran port -f uninstall gimp and port install gimp again, and no change. The log says ...---> Scanning binaries for linking errors Warning: Error parsing file /Applications/MacPorts/GIMP.app/Contents/MacOS/GIMP: Error opening or reading file ---> No broken files found., so just the usual, except the warning. The GIMP.app is not created. There is a binary in /opt/local/bin/gimp, but running it does nothing. Previously, MacPorts also created the .app and judging from the warning it still tries to. – oarfish Nov 7 '15 at 17:08
0

I just stumbled over this post, while looking for a similar issue with inscape. The following happened:

  • I Installed inkscape on a MacOS 10.14 macbook via macports 2.5.4 (which was a quite painful experience...)
  • At some point I did a system update after which inkscape seized to work - some issue with "dyld: Library not loaded: /usr/local/opt/poppler/lib/libpoppler.74.dylib"
  • Hence I removed the Inkscape binaries manually from /usr/local/bin
  • When trying to run

    $ sudo port install inkscape

I received an error message the inkscape files are unavailable at /usr/local/bin and didn't find any means to fix this issue.

Thanks to this post here I was able to resolve the issue by typing

$ sudo port -f uninstall inkscape

which enabled me to install inscape once again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .