2

I'm getting the following nondescript error whenever I try to use Boot Camp assistant under 10.11.1 to setup a Windows 10 install.

Boot Camp - Can't Install The Software

This happens while (or possibly right after) the process is downloading the Windows support software. I've tried the process about 10 times now with the same result every time.

Anyone have any idea what could be going wrong or how I get a more descriptive error out of the Boot Camp process?

I'm on a MacBook Pro (Retina, 15-inch, Mid 2015) and my Boot Camp version is 6.0.0. I'm using a Windows 10 ISO downloaded directly from Microsoft and I've tried downloading multiple times and comparing the file hash to confirm that the ISO isn't getting corrupted.

  • Mac model, year, Boot Camp version? Not all Macs can use Win10 on Boot Camp. – Tetsujin Nov 2 '15 at 20:36
  • Please edit your question to provide the info. Comments are ephemeral & may be deleted at any time – Tetsujin Nov 2 '15 at 20:38
  • Best I can suggest, until someone finds something better for you to try, would be to have Console open as you try it - see if it provides any relevant info – Tetsujin Nov 3 '15 at 7:37
  • Usually Boot Camp wants to copy the drivers it downloads to some external media device once it has finished. Seeing as your error doesn't speak of any networking issues, I'm assuming there were no problems downloading the drivers. Maybe it's getting stuck on the second part, copying the drivers to an external media device? I've always used 4GB USB drives. They need to be formatted as MS-DOS FAT. This can be achieved using Disk Utility. – MorganR Nov 3 '15 at 14:36
  • @MorganR, I was installing Windows to a portion on the MacBook hard drive and no external drives were involved. Eventually got it to work, see below. – James McMahon Nov 3 '15 at 17:54
1

I was getting this error as well. In my case the initial download was completing, and then the supremely unhelpful "Can't install the software" error was popping up. There was nothing in system.log to indicate why.

I eventually figured out that it was due to the fact that I was running Boot Camp Assistant as a non-administrative user (for security reasons my day-to-day user is non-admin). Even though, as with most apps that require admin privileges, it asks for an admin password when run as a non-admin user, in the case of this particular app it doesn't work. You must actually be logged in as an admin user.

Also, make sure you don't have any other users logged in or any other apps running while you are doing the Boot Camp setup, or it may hang at the last minute.

Overall this is a flaky bit of software. When it works it's great, but it copes spectacularly badly with failure. The fact that it insists on re-downloading the support software every time is particularly galling (have these people never heard of rsync?) when you end up running it dozens of times trying to get it to work...

  • This was the issue for me - I don't run as admin normally, and it would fail at the end of the download. Logging in as my admin account allowed me to get through the unpacking phase successfully. – kop48 Apr 13 '16 at 20:58
0

TLDR: Was able to get it to work after trying many times.

This error appears to be a truncated version of the "Can't download the software because of a network problem" error. On previous versions of Boot Camp it was possible to defer the Support Software download until after Windows was installed. This is no longer possible with Boot Camp 6.

It appears the issue was with Apple's servers and trying over and over again eventually yielded success. It took around 30 attempts over the course of several hours. It wasn't a network issue as I was able to successfully connect to other servers and I could see data being transferred from an Apple CDN. The issue has affeced other people as well:

I imagine this will be something Apple eventually sorts out with their servers and / or the Boot Camp software. But for now the solution is to try until it works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .