11

I have two display profiles in my 13-inch mid-2010 MacBook Pro. The default one and a display with warm colors that I use in darker environments.

Since I updated to El Capitan, OS X is changing my display profile to the warm one without asking. I really don't know whats is going on and I wasn't able to find any post with a related problem.

This is the screen os color profiles:

enter image description here

  • Do you use f.lux? I had an issue where my external monitor randomly changed to the sRGB color profile and quitting f.lux solved it. – 3871968 Nov 2 '15 at 17:02
  • I really don't know what f.lux is, so I think I'm not using it. I also didn't use an external monitor for a while now. I thought that it might be the Automatically Brightness Adjustment, but I have no way to test it. – McLeary Nov 2 '15 at 17:08
  • f.lux is an app that automatically warms the color temperature of your screen after sunset: justgetflux.com – 3871968 Nov 2 '15 at 17:10
  • 4
    I have a similar problem on my late 2011 13" MacBook Pro. I always use a darker/warmer color profile, but sometimes, typically upon startup, it switches to the default color profile. When I open color profile options, the correct one is selected and it automatically switches back. I also used to use an external monitor with a calibrated profile but haven't used one for a while. This is probably a bug Apple will need to patch. – kal-al Jun 5 '16 at 18:10
  • 1
    Your display colors are stored in /Library/ColorSync/Profiles/Displays in el capitan. Try to move the warm profile to your user folder in ~/Library/ColorSync/Profiles. You need to create this Folder because on fresh el capitan installation this does not exists. – dante12 Sep 4 '16 at 11:50
3
+200

If you use F.lux

F.lux has a known issue (see seventh bullet point) of display flickering on El Captian. You can fix it by turning off your Mac's Automatically Adjust Brightness feature.

To turn off Automatically Adjust Brightness, go to System Preferences -> Display.


If you don't use F.lux

Your issue sounds like a bug in OS X. It may be fixed in Sierra, but if you don't want to try out the beta first, you can easily stop it from happening by switching to F.lux:

  1. Delete the Warm Colors profile (or any other display profiles you have set up in System Preferences -> Display -> Color)
  2. Download F.lux and follow the setup to get your ideal screen warmth (if you want your screen to turn warmer at night).
  3. Set up F.lux to turn on automatically at your desired time or just turn off that functionality and turn it on/off manually.
  • I don't know if this is a MacBook only problem, but I am working with a MacPro and an Apple LED Cinema Display. I created a warm profile and I'll report if it is happening in this configuration. – McLeary Sep 8 '16 at 15:52
  • @McLeary If it happens again, try following the answer I put above (delete the Warm Colors profile and use F.lux instead). – owlswipe Sep 9 '16 at 10:59
2

First of all, delete the profile to which your display changes to automatically (my display was switching to night mode even after I deleted that profile).

What you need to do after deleting is restart your Mac. Now, it won't switch the displays automatically.enter image description here

  • I am not seeing this issue after some updates on macOS. If I try to follow your advice if I see it again. – McLeary Sep 23 '17 at 21:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .