Some time ago our company laptops started to overheat. At first it was nothing serious but after a while almost all our macbooks started to act more like ovens than computers. The issue seems to lie in Active directory we use for both our PCs and MACs. Logs are getting about 4000 messages per second. Every time its the same thing.

opendirectoryd: assertion failed: 14E46: AppleLdap + 24580 {4B807ACD-E59B-3635-99BA-B08122AA513C}: 0X0

Even if I disable messaging for the process the opendirectoryd still takes more than 90% of CPU. If I at least knew what the error message means than maybe I could do something about it. The issue is even worse on El Capitan in fact it is so bad that machines with it won't even boot properly.

If anyone knows how to fix this or at least knows what the message means I would be most grateful.

  • Does disconnecting the internet help to prevent it? What version of OS X do you run? Have there recently been changes to the way you setup your servers? Nov 2, 2015 at 10:21
  • 1
    Yes being disconnected from internet helps. Nov 2, 2015 at 10:32
  • Might be you can give us more details on your setup. Because when disconnecting from the internets works than you probably have your settings wrong. Nov 2, 2015 at 10:32
  • God I wish I could give you more, but turns out nobody knows how it was set up around here. Not to mention that our "network experts" refuse to acknowledge that their network might be at fault and management doesn't put any pressure on them because they use Windows. Edit: btw I understand that I'm giving too little info, but right know this is all I have and will be in foreseeable future. Nov 2, 2015 at 10:45

2 Answers 2


I've got an answer to this problem for people coming here with this issue who aren't using Active Directory (meaning that it can't be the cause).

For me the problem was my Dropbox was struggling with broken symlinks inside my Dropbox folder. I had about 20-25 of these broken symlinks. You can see if this is the problem for you by whether the problem goes away when you quit Dropbox (and wait a bit for the Activity Monitor to calm down).

You can see the location of these broken symlinks with:

cd ~/Dropbox
find . -type l ! -exec test -e {} \; -print

If you want to then delete these (they're broken after all, just get rid of them), you can run this:

find . -type l ! -exec test -e {} \; -print | xargs rm

I quit my Dropbox program before doing this. After turning it back on, the problem was gone!

Note: I ran this with gfind instead of find, which is the GNU version of find that you can get by doing brew install findutils. It should work perfectly fine with regular find though.

  • Note: find . -type l ! -exec test -e {} \; -delete will also work for the removal part. Jan 3, 2018 at 11:12
  • 1
    This was the problem for me too. Now fixed, thanks. Nov 21, 2018 at 4:03
  • 2
    Magic. Many thanks. That was very strange. Seems like Dropbox all of a sudden har started to sync over a symlink from a Linux machine, where I had a link out from the dropbox folder (dropbox folder residing on a spindle disk) to an SSD. Previously, this worked as I intended (that folder - git - being on the SSD, while the rest on the bigger spindle disk), but now it instead synched the link itself.. Which did not make sense on the target Mac. edit: And just now I found this: help.dropbox.com/installs-integrations/sync-uploads/symlinks
    – stolsvik
    Jan 20, 2020 at 22:44

OS X: If the opendirectoryd process CPU utilization is high after updating to OS X v10.9.5

You might see an increase in CPU utilization of the opendirectoryd process on systems bound to Active Directory that are updated to OS X v10.9.5.

After updating to OS X v10.9.5, Activity Monitor might report high CPU utilization for the process "opendirectoryd" on Macs that are bound to Active Directory. You can edit the Active Directory search path to correct this issue:

  1. Choose System Preferences from the Apple menu. Click the Users &
  2. Groups icon in the System Preferences window. If the lock icon is locked, click it and enter the name and password of an administrator.
  3. Click Login Options, then click Edit.
  4. Click Open Directory Utility. If the lock icon is locked, click it and enter the name and password of an administrator.
  5. Click Search Policy.
  6. Click Authentication.
  7. Remove "/Active Directory/EXAMPLE.COM” from the search path, leaving "/Active Directory/EXAMPLE.COM/All Domains” (substitute your domain for example.com).
  8. Quit Directory Utility.

I shamelessly copied the above from support.apple.com. I hope this can help you out, but for now I have no clue on your system setup.

  • We had the path set up this way already so this is not it. But thanks. Nov 2, 2015 at 10:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .