6

I updated to El Capitan yesterday (on MacBook Air 2014). I then decided to install Kali Linux 2.0, and boy it's been one problem after another, so far nothing has gone the way it's supposed to. Without going too much into details, some of which include (problems downloading rEFInd, burning the iso image onto the thumb drive and etc.). I think I managed to do that.

So now I try to reboot my Mac, after the rEFInd boot screen shows up I plug-in the usb and I get only one volume (the legacy OS one) and the guide for installing Linux says try installing rEFInd and try again, but I already have rEFInd (you need to have 3 volumes as it shows here).

enter image description here

If I try to boot the legacy folder it says:

Starting the Legacy Loader
Using Load Options USB
Error: Not Found while loading legacy loader

Make sure u have the latest firmware update installed
Hit any key to continue

Any help is appreciated :) I'm really getting frustrated trying to install Kali, first time though.

P.S. There is a very high probability I've messed up somewhere before, because as I said, I've been running into almost every problem out there, googling, and trying to go around it, most of the time not even sure what I am doing, so... I may have messed smth up on the way.

BTW my laptop can't read my USB, which is to be expected, but I will be able to turn into readable later, won't I?

More Details:

rEFIdn used - 0.9.2 How I configured it: Iunzipped it, I had to turn my security settings off in the recovery mode, and I think that worked for me after I ran it as it's is supposed to be ran, as said in the link. Long process, I don't remember all of it.

the dark screen

  • alright, sorry for the mess, you guys wouldn't know how to solve this would you? – RainMan Nov 1 '15 at 8:53
  • Well the machintosh volume is always there, so I mean that there are supposed to be 2 extra volumes, but there is only one, or 3 in total, but I have only 2. The kali site, mentioned it as 2 as well. But really appreciate you going through all the trouble, I imagine that's a lot to do, unless I'm really bad at this, cause it took me the lot of yesterday to get to this point. Thank you :) – RainMan Nov 1 '15 at 9:07
  • well I just moved to Vancouver, so London's time is 8 hours ahead, so is it GMT -8? 1 am here – RainMan Nov 1 '15 at 9:12
  • Which version of rEFInd and how did you install/configure it? Please add that to your question by editing it. – klanomath Nov 1 '15 at 11:24
  • @RainMan How did you solved it at the end ? I have that same error, except I'm booting on USB – Bigood Dec 2 '16 at 14:21
4

I set up a MacBook Air 2013 from scratch and tried to install Kali Linux 2.0. The install was successful, the big problem is the Broadcom wireless card though. But that's probably a second question.

Here is what I did:

  1. First I made a fresh install of El Capitan 10.11.1 after repartitioning the internal drive to 1 partition with a GUID partition table.
  2. After configuring El Capitan I downloaded Kali Linux and rEFInd 0.9.2
  3. Then I dd'ed the kali iso image to a thumb drive:

    First get the disk identifier of the thumb drive and unmount it:

    diskutil list
    

    My thumb drive had the disk identifier disk2.

    diskutil unmountDisk /dev/disk2
    

    then dd the iso to the thumb drive:

    sudo dd if=/Users/your_user_name/Downloads/kali-linux-2.0-amd64.iso of=/dev/rdisk2 bs=1m
    

    The thumb drive will be bootable without installing rEFInd.

  4. Then I booted to Recovery HD by holding cmdR while booting. Disable System Integrity Protection in Terminal with

    csrutil disable
    
  5. Reboot to Internet Recovery Mode by holding altcmdR.You will see a spinning globe animation while booting.

  6. Since you probably have a CoreStorage partition after installing El Capitan you have to resize it. I doubt that the disk partition tool in the Kali Live USB drive succeeds with that. Open Terminal and enter:

    diskutil cs list
    diskutil cs resizeStack lvUUID size
    

    lvUUID is the UUID of the Logical Volume. It's the last one listed in the output of diskutil cs list. The size has to be in t, g, m or k. Example: If your main disk has 250 GB and you need 40 GB free space to install Kali Linux to, enter 210g.


    If you don't have a CoreStorage stack on your Mac you may choose Disk Utility to resize the main volume. The Recovery HD should be moved automatically in both cases.

  7. Reboot while holding the alt key. Boot to the Windows partition of the thumb drive. Choose Graphical Install and configure the locale settings. The network interface install will probably fail. Choose none. Use the defaults of the disk partitioning tool. It will choose the empty space on your main disk to create a small boot partition for grub, a main partition and a swap partition. Then Kali Linux will be installed. Install grub to the mbr of your main disk.

  8. After a reboot the Mac will boot to OS X. Eject the Kali Linux installer thumb drive.

  9. Install rEFInd:

    cd /Users/your_user_name/Downloads/refind-bin-0.9.2
    ./install.sh
    

    Rename the refind folder and the efi file:

    cd /Volumes/ESP/EFI
    mv refind boot
    mv boot/refind_x64.efi boot/bootx64.efi
    

    Immediately after installing rEFInd the EFI volume is mounted at /Volumes/ESP and the install script fails to unmount it. If you mount disk0s1 later manually (e.g. after a reboot) with diskutil mount /dev/disk0s1 it will be mounted to /Volumes/EFI! Then you have to use cd /Volumes/EFI/EFI instead.

  10. Quit Terminal and reboot while holding alt

  11. Choose EFI Boot at the Mac boot screen and then Kali Linux at rEFInd boot screen.
  12. Set up Kali Linux

Everything except the WLAN interface (and AFAIK the webcam) works now.

To further set up Kali Linux check the following resources:

HOWTO : Kali Linux 1.0.6 on MacBook Air (Mid 2013) 13 inches

To get the Broadcom chip to work check:

How to install Broadcom BCM4360 on debian on Macbook pro
How do I install build-essential without an Internet connection?
Kali 2.0 Installation Tips for Macbook Pro 2015 Retina
Broadcom firmware
Installing Debian On Apple MacBook Air6-2
b43 and b43legacy

Until now I haven't been able to get WLAN working but I'm investigating that and I will extend the answer as soon as I'm successful.


After setting up everything successfully boot to the Recovery HD again and reenable System Integrity Protection in Terminal with

csrutil enable
  • WOW, an impressive review, I remember hearing smth about WLAN not working if u're using USB Live I think, may be virtual box, don't remember, but they said then the Linux can't access the Wi-Fi device in the laptop. anyway, Huge thank you, will have to try now again. One thing I'm interested, though, is if I already booted the usb drive, and it doesn't work, how do I unboot it, and try again? Do I just delete all files on it? – RainMan Nov 1 '15 at 18:17
  • @RainMan You don't have to delete the files because the command sudo dd if=.. of=.. bs=.. in step 3 will overwrite your thumb drive. – klanomath Nov 1 '15 at 18:20
  • oh alright, what about, I'm seeing u're using a different command, from them using in the guide, they use: sudo dd if=kali-linux-1.0.9a-amd64.iso of=/dev/disk6 bs=1m and u add, user, download, is this important? – RainMan Nov 1 '15 at 18:52
  • @RainMan In my answer I linked the Kali Linux 2.0 download and so I adapted the dd command – klanomath Nov 1 '15 at 18:54
  • I tried this and got the Kali boot menu to appear, but it's frozen. It's also really small and in the upper right corner. What could be going on? Here's an image to see what's happening: imgur.com/a/U04dO – addison Sep 23 '16 at 18:35
1

You have to get the order right first.

1) Download rEFInd and UNetbootin

2) Reboot while holding the Option key upon boot

3) Go into Recovery HD and create a partition for Kali

4) Open Terminal and type: csrutil disable

5) Reboot then use UNetbootin to 'burn' the ISO onto your USB

6) Reboot with USB plugged in and holding the Option key upon boot

7) At the rEFInd screen you will have the choice to boot from the USB

8) Boot from the USB and install Kali as normal

As for your issue with WiFi, here's a simple fix. Here is a page from a wiki for Arch but it is the same for Kali as well. Since Kali is Debian-based, use the broadcom-wl and not the broadcom-wl-dkms as the driver.

Then there's the webcam thing. There's a driver hidden in the OS X partition at:

/System/Library/Extensions/IOUSBFamily.kext/Contents/PlugIns/AppleUSBVideoSupport.kext/Contents/MacOS/AppleUSBVideoSupport

These one, two and three sites all give detailed instructions about how to extract and load the driver for the iSight camera. If you're looking through the firmware and still can't find the right one, check this or this site.

  • This might be a stupid question, but how do u burn the ISO to usb using unetbootin, cause I don't see them supporting Kali, I see Debian, and whole bunch of other linux distributions, but not Kali :( – RainMan Nov 1 '15 at 23:04
  • @RainMan Kali is based on Debian. Does that help? – tjt263 Nov 2 '15 at 2:13
  • I'm not sure, cause when I pick debian, then it gives a lot of options liek stable net install, testing, ro unstable netinstall, and added to them give x 64, or HD Media, so which one do I pick? – RainMan Nov 2 '15 at 2:18
  • @RainMan There are 2 radio buttons in UNetbootin: Distribution and Diskimage. Choose Diskimage and make sure the dropdown menu next to it says 'ISO'. Now click the three dots '...' on the right and select the Kali ISO file. Select your USB drive at the bottom and finally hit 'OK'. – Jack of all Spades Nov 3 '15 at 1:25
  • @TRT oh, alright, great, now I see it, TY. Just a quick question will this make my usb a bootable kali, or willl I be able to install it on my mac, so I don't need a usb? – RainMan Nov 5 '15 at 17:02
0

RainMan here, forgot my acc, anyway, managed to install Kali - moving forward - however, because before that I managed to mess up several times, including wiping out my entire OS, second time I installed Kali I forgot to get Refind before it.

So I installed Kali, and looked it over, then decided i want to go back to Mac HD, so i restarted my laptop, got into Mac HD, and now I don't know how to get back into Kali, can't see it. I'm sure it's on my hardware somewhere, but no idea how to access it, any ideas?

Thank you

0

http://www.zealpeal.com/dual-boot-os-x-el-capitan-on-macbook-pro-with-kali-linux/ Check out this for full guide on installing Kali linux on macbook pro with El Capitan along with instrustions on how to install rEFInd.

  • Answers on Ask Different need to be more than just a link. It's okay to include a link, but please summarize or excerpt it in the answer. The idea is to make the answer stand alone. – nohillside Dec 25 '15 at 18:34
0

Kali linux image is available for easy install within this new mac virtualization tool called Veertu. Search for Veertu in your Mac Appstore and you will find it.

-2

For the wlan just use the command sudo modprobe -r acer_wmi

  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the answer you provided will solve the problem or is better than others out there. Providing links can also help the OP, and others, find additional info for themselves. See How to Answer on how to provide a quality answer. – fsb Jan 12 '17 at 19:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .