1

I'm running OS X El Capitan.

I want to run rsync in daemon mode but I'm unable to do it. Here is the error from /var/log/system./log:

rsyncd[1329]: unable to bind any inbound sockets on port 873
rsyncd[1329]: rsync error: error in socket IO (code 10) at /BuildRoot/Library/Caches/com.apple.xbs/Sources/rsync/rsync-47/rsync/socket.c(477) [receiver=2.6.9]

Any advice?

  • port number is less than 1024, hope you used sudo. Please add more details. – sdayal Oct 31 '15 at 9:15
  • Yes, I used sudo. Strange thing happened. I have two machines, a MBP and an iMac. The daemon on the MBP runs now. – cahuk Oct 31 '15 at 9:29
  • Cool. Could you explain what you did. Did you have to disable System Integrity Protection (rootless) for this? – sdayal Oct 31 '15 at 15:37
  • That's the problem, I don't know what I did. Anyway, I figured out that I can run the rsync daemon with the --port option. The port number has to be higher than 1024. But... my NAS can't access the iMac. So now I run a daemon on the NAS and I push the files from the iMac (before that I pulled the files from the iMac). – cahuk Oct 31 '15 at 18:04
  • One more thing. I have firewall enabled but I never get the allow/deny window asking if I allow incoming connection for the rsync command after I ran the rsync command with the --daemon option. So I allowed rsync incoming traffic from the command line. I think my firewall behaves pretty strange (on the iMac). – cahuk Nov 1 '15 at 10:28
1

You'd see that error if you don't have privileges or a process is already bound to port 873.
Anyway I just wrote a small 'one button' GUI app which starts the rsync daemon for you: http://bonhardcomputing.com/rsync-server/
It also has the most modern version of rsync built into it...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .