2

I just finished updating my OS X to El Capitan, and when I went to open AU Lab, it said the Soundflower input and output could not be found. I checked system preferences and both Soundflower 2ch and 64ch are no longer listed in the Sound tab. I uninstalled and reinstalled both Soundflower and AU Lab twice but this hasn't fixed the problem. If I try to open AU Lab and run my equalizer preset anyway I get a high pitched screeching noise that doesn't go away.

I've used this same preset for a couple of years now and never had a problem, so I am pretty annoyed by this. I can understand some compatibility issue that could probably be worked around, but the fact that it just blatantly deleted the channels from system preferences doesn't really make sense to me. Reinstalling didn't put them back. Anyone have any insight/suggestions? I refuse to go back to listening to things through the default of MacBook speakers.

edit: upon further inspection, it seems as though it actually just completely wiped out Soundflower and refuses to accept it back... even after installing and restarting, it doesn't show up in the Applications folder. Soundflowerbed is still there, but says "Soundflower is Not Installed!!" What is this about?

  • Do you have a Time Machine backup? – At0mic Oct 31 '15 at 3:17
  • Are you running 10.11.0 or 10.11.1? - There is a significant audio bug in 10.11.0 which breaks many pro audio rigs. Should be fixed in 10.11.1. I found the 'best' method was to revert to 10.10.5 then re-update directly to 10.11.1 which carried my working system properly AU plugins are now working again. Having said that, I'm surprised you managed to keep Soundflower working for so long - I had to abandon it at Yosemite, after many kernel panics. – Tetsujin Oct 31 '15 at 7:49
  • I am running 10.11.1, and this was my first attempt at updating to El Capitan, so I'm not sure why it is doing this if the problem was already addressed. I am also surprised it had been working for so long with no issues because I had seen lots of people having serious problems at Yosemite. – fcqr Oct 31 '15 at 11:36
  • There's a v2.0b2 which might be worth a try - signed version so it ought to install correctly - github.com/mattingalls/Soundflower/releases Most of the 1.6x versions I ever tried were badly broken since Mavericks, so eventually I gave up & I now use Audio Hijack for internal routing, if I need it. Make sure to check the old version is fully uninstalled [whatever the OS says, it might still be there] – Tetsujin Oct 31 '15 at 11:50
  • 1
    Thanks for the tip. It didn't work on its own, but I fiddled with it a little and went through the build in Xcode, and it seems to be working now. Channels have been put back in system prefs, equalizer preset opens in AU Lab without the horrible noise, and the sound is going through it. The periodic clicking also seems to have disappeared, which is great. Thanks, man! – fcqr Oct 31 '15 at 17:13

You must log in to answer this question.

Browse other questions tagged .