1

When I attempt to update any app on my iPhone 6, the little process circle that appears after you click "update," just continues to swirl, remaining in that state as long as I let it. I have to quit the app store app or reboot my phone to get it back to the update button (even if I try pressing the swirly circle, it does not change). I've tried a hard reset, tried deleting any recently added apps. Some apps I'm unable to delete, because they appear to be in a transitional state (partially greyed out, like they're downloading or updating) and, I cannot see any third party apps when I go into settings, manage storage - it loads all the native apps, then appears to be in the process of loading the rest, but never continues. It shows i have 2.5gb available memory, so I should be able to at least update some apps, unless that figure is not correctly representing everything on my phone. I'm running iOS 9.0 and am extremely apprehensive about updating, because my phone was bricked for two days when i updated it to 9.0. I have an iPad air 2,which i had no trouble updating to 9.0, and am experiencing no issues with now - I'm able to update and download apps fine. And yes, I did log out of the iTunes app store, then back in, but it made no difference. I've not connected it to iTunes on my computer, because I'm currently servicing my pc. Any ideas? I've tried everything i can think of.

1

It seems you're in a tight spot and have a pretty tight knot tied up with some really solid thinking.

Let's unravel things a bit. Get out a piece of paper and start writing times and limiting things you change to one at a time.

  1. Put the phone in airplane mode and power it off. (note what you did and the time)
  2. Power it on while disconnected and go delete all the apps that are stuck that you can afford to lose and re-download. (keep writing times and actions :-)
  3. Check your storage usage and make sure each app gives you a number. If you can't get the usage numbers to paint while in AirPlane mode, start deleting things that take a lot of space. Movies, songs you can re-download until the device is working.
  4. If you can't get it to a sane place in AirPlane mode, consider a call to AppleCare or just getting a backup to iTunes and wiping the device.

If you can resolve the transitory apps and get things working, go ahead and re-connect to the network and see if you can let the rest of the apps download. If so, proceed:

  1. Turn off all background refresh in settings > general
  2. Turn off Handoff (same place - higher up)
  3. Set the time wrong - about 4 minutes in the past
  4. Enable automatic time setting and verify that it returns to the correct time
  5. Reset network settings (which will clear up several things and perform a minimal restart)
  6. Pick one app that's small. Clicker is a good one Try downloading it.
  7. If that fails, sign out of the App Store and power off the phone
  8. Start the phone and try to download Clicker again.

If that fails, Apple support might be needed to assist. You could try changing your network (use LTE or cellular data if you're on WiFi now) or change WiFi to another location. The good thing about your notes is you will have some very specific times and steps and can start to notice patterns and perhaps ask a follow on question if needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .