25

I have a laptop and a desktop both running 10.11.1; on the laptop I found a way to set up Spaces so that CTRL-1 would take me immediately to screen 1 and similarly for all the other screens. I rely on that convenience. But on my desktop I am still stuck with this stupid Mission Control 2-step procedure. I KNOW it's possible, but I have been unable to reproduce this convenience on the desktop. Can anyone remind me how it's done?

32

You can enable this feature in the "Keyboard" preference pane.

  1. Open System Preferences (e.g., from the Apple menu)
  2. Click on the "Keyboard" preference pane
  3. Go to the "Shortcuts" tab
  4. Choose "Mission Control" from the menu on the left
  5. Look in the box on the right for "Switch to Desktop 1"
  6. Enable the feature by "checking" the check box
  7. Be sure that the keyboard shortcut is "^1" ("^" means Control)

If you only have one desktop right now, then you will only see "Switch to Desktop 1", but by placing a checkmark in the box, the feature will be enabled as you add new desktops.

enter image description here

5

Here's another approach you may find useful; it's been my favorite for years, as it makes for an easy reach, one-handed keyboard shortcut (hotkey trick), to switch between spaces/desktops: Alt. + Arrow key

Starting from the second screenshot above (or below depending how the post is uploaded) of the System Preference window for Keyboard: 1) Select Shortcuts, then 2) Notice just below the "Keyboard Text Shortcuts Input Sources" menu, that it reads: To change a shortcut, select it, click the key combination, and then type the new keys. 3) Select "Move left a Space" / "Move right a Space" 4) Click/tap on the default symbols (i.e., the default shortcut that requires two hands) Ctrl + Arrow, and simply type in "Alt + Arrow" and viola = a one handed keyboard shortcut to switch between spaces.

I realize, a three finger swipe on the trackpad works too, and I love the trackpad, but I prefer keyboard shortcuts where they can be created/applied.

Lastly, I believe this will work on all Apple keyboards, laptop and desktops alike, at least it has on all five in our house (2 MBooks, 1 Air, 2 iMacs).

  • Great answer. Note that click the key combination means double-clicking on the displayed key combo (e.g., ^->) after it has been selected with the checkbox. Thanks! – Peter Gluck Jun 26 '17 at 21:45
4

Troubleshooting possibilities, assuming everything already looks OK re JM's answer...

  • On a keyboard with a 10-key pad, the 10-key & qwerty numbers are separate controls. The default key commands use qwerty so you need to change them specifically to 10-key if that's what you use.

enter image description here enter image description here

  • Secondly, though the commands are added with each new Space, they are not enabled by default.

  • Thirdly - if you have only the same number of Spaces as you have monitors - and also "Displays have separate Spaces" in Prefs > Mission Control - then Switching cannot work until you add one more Space

  • Another possibility, courtesy of Avram [which I cannot test as I don't have anything to 'swipe' on]

    I believe this state occurs when you inadvertently make a swipe gesture while a ctrl-key is held down. I can't be sure of that, but the fix is to do exactly that: hold down the ctrl-key, and then do the desktop-switching swipe gesture (for me it is 3-finger swipe left or right).

4

Went hunting for this myself today, looks like control and control do the job.

  • dang, is this new? it's built-in, adding a custom shortcut is kind of a minor waste of shortcuts – pneumatics Dec 19 '17 at 23:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .