2

According to html5test.com, Safari now supports HTML5. I am specifically interested in the HTML5 tag parameter required.

However, when I add the required parameter to my form, Safari ignores it. I have tested the page with FireFox and it works.

So, does Safari support HTML5 or not?

3

Safari does support HTML5 and does support form validation, however support for 'required' in Safari on OS X and iOS is 'partial'.

Partial support refers to lack of notice when form with required fields is attempted to be submitted.

Source: caniuse.com/#search=required

Implementation is off-topic here, but feel free to search for solutions on Stack Overflow.

0

Safari does not support this attribute, you need to use JavaScript. This page contains a hacky solution, that should add the desired functionality:

http://www.html5rocks.com/en/tutorials/forms/constraintvalidation/#toc-safari

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .