0

We noticed this week that our Macbook wifi connection was slow. On inspection, we discovered that the wifi wasn't auto-connecting to our network, but rather one named ATT5g---.

If I selected our network, then went BACK to that network, it required a password to login. If I turned off our wifi and turned it back on, it would select the ATT wifi first.

Of course, I thought, "man in the middle" attack? (Because I'm not really tech savvy). But it seems like it would be a bad one, as it was easily discoverable and provided the IP address. Still ...

In getting rid of the network as a "preferred" network, I noticed in the Advanced setting a slew of networks we've connected to via iPhone/iPad - like pizza joints, libraries, etc. So I started connecting some dots.

  1. ATT sounds like it's probably Uverse.
  2. The neighbors across the street have Uverse.
  3. My son is friends with the neighbors and connects his iPhone to their wifi when he goes over
  4. We have iCloud keychain.
  5. Chances are, through iCloud, the Macbook picked up on the wifi network and started automatically connecting to it.
  6. The neighbors run a business from their house, so they likely have more than one router (hence the multiple ATT wifi networks) and a stronger, safer network.
  7. Those routers are likely synced. (My son says he can't remember their network name and the ATT wasn't familiar. That he thinks he connects to "linksys.")
  8. No other device in the house connects to that wifi (no iPads, not my Dell, etc.)

Now, I couldn't get my son's iPhone to connect to the ATT wifi, which is a sticky in the wicket. I see the ATT wifi, but requires a password if I try to connect. But maybe because it's a specific router and not the linksys?

Does that make sense? Have you heard of Macbooks connecting to other wifis as a regular issue?

1

This is not an issue that I have ever seen before. A Macbook automatically connecting to a secured network is something out of a science fiction book.

As for your sons iPhone, type your subnet mask into your address bar and mess around with the settings for you WEP Key and add his iPhones mac address to your router settings. This should enable your router to talk with your sons iPhone in this case that it is not connecting.

You can also go ahead and remove the network from his phone by forgetting it, and re-entering the credentials for your router in again manually so it can have a fresh start at trying to get to know your sons iPhone connection. My iPhone has trouble recognizing my iPhone sometimes and adding the mac address to my router settings fixed the issue but I am more experienced with stuff like than than your average Joe so try and "Forget This Network" and see if that works if not, try the first option. If all else fails, give Apple a call.

  • My guess is that the Macbook, through iCloud keychain, was able to connect because the iPhone automatically connects. Sort of a "shared access." I'm not terribly tech savvy. Just enough, so to speak. I did verify that it was the neighbors network. It's also been suggested that our WiFi dropped at some point, and the Macbook picked up the strongest, most secure network it could find - which was the neighbors. Access was through the synced keychain. Again, not sure if that makes sense, but it seems plausible. – tomten3000 Oct 30 '15 at 16:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .