5

Just got a new MacBook Pro (Retina, 13-inch, Early 2015), but there are several problems with bluetooth. Most of them occur when waking from sleep:

  1. Sometimes the bluetooth icon shows "Not available". The bluetooth hardware then also doesn't show up in System Information.
  2. Sometimes the bluetooth icon and preferences indicate that it's turned off, but nothing happens when I click "Turn on".

The only remedy for these problems is to completely restart the computer. In some cases, it hangs on the 'shutdown loading spinner', and then restarts with a kernel panic message. I attached the latest panic log below.

I tried trashing the bluetooth preferences and resetting the SMC, but that doesn't seem to permanently fix the problems.

Could this be a hardware issue?


*** Panic Report ***
panic(cpu 1 caller 0xffffff800edd6bba): Kernel trap at 0xffffff7f900ed402, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x00000000000000bf, CR3: 0x0000000011f99000, CR4: 0x00000000003627e0
RAX: 0x0000000000000000, RBX: 0xffffff802e913300, RCX: 0xfffffffe803b8924, RDX: 0x0000000000000001
RSP: 0xffffff81f7513b20, RBP: 0xffffff81f7513b30, RSI: 0xffffff802f0dd000, RDI: 0xffffff802e913300
R8:  0xffffff802d794000, R9:  0x0000000000000001, R10: 0x0000000000000000, R11: 0x0000000000000028
R12: 0xffffff802ec10a00, R13: 0xffffff7f900a422c, R14: 0x0000000000000000, R15: 0xffffff802f0dd000
RFL: 0x0000000000010286, RIP: 0xffffff7f900ed402, CS:  0x0000000000000008, SS:  0x0000000000000010
Fault CR2: 0x00000000000000bf, Error code: 0x0000000000000000, Fault CPU: 0x1, PL: 0

Backtrace (CPU 1), Frame : Return Address
0xffffff81f75137b0 : 0xffffff800ece5307 
0xffffff81f7513830 : 0xffffff800edd6bba 
0xffffff81f7513a10 : 0xffffff800edf4313 
0xffffff81f7513a30 : 0xffffff7f900ed402 
0xffffff81f7513b30 : 0xffffff7f9019fadb 
0xffffff81f7513b70 : 0xffffff7f9019bf24 
0xffffff81f7513b90 : 0xffffff800f2b8538 
0xffffff81f7513c00 : 0xffffff7f9019beab 
0xffffff81f7513c40 : 0xffffff7f901c7e14 
0xffffff81f7513d20 : 0xffffff7f901ad013 
0xffffff81f7513e70 : 0xffffff7f901acf38 
0xffffff81f7513f30 : 0xffffff7f900d1117 
0xffffff81f7513f50 : 0xffffff7f900d10c6 
0xffffff81f7513f70 : 0xffffff7f900d113c 
0xffffff81f7513f90 : 0xffffff7f900d123e 
0xffffff81f7513fb0 : 0xffffff800edd15d7 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOBluetoothFamily(4.4.2f1)[B3BAA668-8A2E-35FC-9683-5D3C87498A43]@0xffffff7f900a0000->0xffffff7f9015cfff
            dependency: com.apple.iokit.IOReportFamily(31)[00ECF188-29A2-3C48-B4DD-B155077F7B3C]@0xffffff7f8ff21000
         com.apple.iokit.IOBluetoothHostControllerUSBTransport(4.4.2f1)[1E8E8B9C-0CFA-3666-8818-36296141B28C]@0xffffff7f9019b000->0xffffff7f901c4fff
            dependency: com.apple.iokit.IOBluetoothFamily(4.4.2f1)[B3BAA668-8A2E-35FC-9683-5D3C87498A43]@0xffffff7f900a0000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[CBAE26D8-0ACB-3C1F-8347-FDCA67EC40B3]@0xffffff7f8fc15000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[8E5F549E-0055-3C0E-93F8-E872A048E31B]@0xffffff7f8f52d000
            dependency: com.apple.iokit.IOUSBHostFamily(1.0.1)[CB073B0F-F3E0-37BD-8091-390367BEDAB0]@0xffffff7f8fa39000
         com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport(4.4.2f1)[0DFBD99C-2B34-3A85-A2DB-FF916490A8CE]@0xffffff7f901c5000->0xffffff7f901cffff
            dependency: com.apple.iokit.IOBluetoothHostControllerUSBTransport(4.4.2f1)[1E8E8B9C-0CFA-3666-8818-36296141B28C]@0xffffff7f9019b000
            dependency: com.apple.iokit.IOBluetoothFamily(4.4.2f1)[B3BAA668-8A2E-35FC-9683-5D3C87498A43]@0xffffff7f900a0000
            dependency: com.apple.iokit.IOACPIFamily(1.4)[CBAE26D8-0ACB-3C1F-8347-FDCA67EC40B3]@0xffffff7f8fc15000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[8E5F549E-0055-3C0E-93F8-E872A048E31B]@0xffffff7f8f52d000
            dependency: com.apple.iokit.IOUSBHostFamily(1.0.1)[CB073B0F-F3E0-37BD-8091-390367BEDAB0]@0xffffff7f8fa39000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
15B42

Kernel version:
Darwin Kernel Version 15.0.0: Sat Sep 19 15:53:46 PDT 2015; root:xnu-3247.10.11~1/RELEASE_X86_64
Kernel UUID: AB5FC1B4-12E7-311E-8E6F-9023985D8C1D
Kernel slide:     0x000000000ea00000
Kernel text base: 0xffffff800ec00000
__HIB  text base: 0xffffff800eb00000
System model name: MacBookPro12,1 (Mac-E43C1C25D4880AD6)

System uptime in nanoseconds: 81497173879650
last loaded kext at 81351682643855: com.apple.driver.AppleXsanScheme    3 (addr 0xffffff7f918d0000, size 32768)
last unloaded kext at 58246112314891: com.apple.driver.AppleXsanScheme  3 (addr 0xffffff7f918c7000, size 32768)
loaded kexts:
org.virtualbox.kext.VBoxNetAdp  5.0.0
org.virtualbox.kext.VBoxNetFlt  5.0.0
org.virtualbox.kext.VBoxUSB 5.0.0
org.virtualbox.kext.VBoxDrv 5.0.0
com.apple.iokit.SCSITaskUserClient  3.7.7
com.apple.iokit.IOBluetoothUSBDFU   4.4.2f1
com.apple.driver.AppleUSBStorageCoexistentDriver    3.7.1
com.apple.filesystems.smbfs 3.0.0
com.apple.driver.AudioAUUC  1.70
com.apple.driver.AGPM   110.20.21
com.apple.driver.ApplePlatformEnabler   2.5.1d0
com.apple.driver.X86PlatformShim    1.0.0
com.apple.filesystems.autofs    3.0
com.apple.driver.AppleOSXWatchdog   1
com.apple.driver.AppleGraphicsDevicePolicy  3.7.7
com.apple.driver.AppleUpstreamUserClient    3.6.1
com.apple.driver.AppleHDA   272.50.31
com.apple.driver.pmtelemetry    1
com.apple.iokit.IOUserEthernet  1.0.1
com.apple.iokit.IOBluetoothSerialManager    4.4.2f1
com.apple.Dont_Steal_Mac_OS_X   7.0.0
com.apple.driver.AppleBacklight 170.8.1
com.apple.driver.AppleLPC   3.1
com.apple.driver.AppleHV    1
com.apple.driver.AppleThunderboltIP 3.0.8
com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport 4.4.2f1
com.apple.driver.AppleIntelBDWGraphics  10.1.0
com.apple.driver.AppleMCCSControl   1.2.13
com.apple.driver.AppleCameraInterface   5.41.0
com.apple.driver.AppleSMCLMU    208
com.apple.driver.AppleIntelSlowAdaptiveClocking 4.0.0
com.apple.driver.AppleIntelBDWGraphicsFramebuffer   10.1.0
com.apple.driver.AppleUSBCardReader 3.7.1
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0
com.apple.BootCache 37
com.apple.iokit.IOAHCIBlockStorage  2.8.0
com.apple.driver.AppleAHCIPort  3.1.5
com.apple.driver.AppleTopCaseHIDEventDriver 86
com.apple.driver.AirPort.Brcm4360   1010.14.1a4
com.apple.driver.AppleHPET  1.8
com.apple.driver.AppleSmartBatteryManager   161.0.0
com.apple.driver.AppleACPIButtons   4.0
com.apple.driver.AppleRTC   2.0
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleACPIEC    4.0
com.apple.driver.AppleAPIC  1.7
com.apple.nke.applicationfirewall   163
com.apple.security.quarantine   3
com.apple.security.TMSafetyNet  8
com.apple.driver.AppleXsanScheme    3
com.apple.iokit.IOUSBMassStorageClass   4.0.0
com.apple.driver.AppleBluetoothHIDKeyboard  181
com.apple.driver.IOBluetoothHIDDriver   4.4.2f1
com.apple.driver.usb.AppleUSBHub    1.0.1
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.0.1
com.apple.iokit.IOUSBUserClient 900.4.1
com.apple.kext.triggers 1.0
com.apple.driver.DspFuncLib 272.50.31
com.apple.kext.OSvKernDSPLib    525
com.apple.driver.AppleGraphicsControl   3.11.33b1
com.apple.driver.CoreCaptureResponder   1
com.apple.driver.AppleBacklightExpert   1.1.0
com.apple.iokit.IOBluetoothHostControllerUSBTransport   4.4.2f1
com.apple.iokit.IOBluetoothFamily   4.4.2f1
com.apple.iokit.IOSurface   108.0.1
com.apple.driver.AppleHDAController 272.50.31
com.apple.iokit.IOHDAFamily 272.50.31
com.apple.iokit.IOAudioFamily   204.1
com.apple.vecLib.kext   1.2.0
com.apple.driver.AppleSMBusController   1.0.14d1
com.apple.driver.X86PlatformPlugin  1.0.0
com.apple.driver.IOPlatformPluginFamily 6.0.0d7
com.apple.iokit.IOSerialFamily  11
com.apple.driver.AppleSMC   3.1.9
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.iokit.IONDRVSupport   2.4.1
com.apple.AppleGraphicsDeviceControl    3.11.33b1
com.apple.iokit.IOAcceleratorFamily2    203.10
com.apple.iokit.IOGraphicsFamily    2.4.1
com.apple.iokit.IOSCSIBlockCommandsDevice   3.7.7
com.apple.iokit.IOUSBMassStorageDriver  1.0.0
com.apple.iokit.IOSCSIArchitectureModelFamily   3.7.7
com.apple.driver.usb.IOUSBHostHIDDevice 1.0.1
com.apple.driver.CoreStorage    517
com.apple.iokit.IOAHCIFamily    2.8.0
com.apple.driver.AppleThunderboltDPInAdapter    4.1.2
com.apple.driver.AppleThunderboltDPAdapterFamily    4.1.2
com.apple.driver.AppleThunderboltPCIDownAdapter 2.0.2
com.apple.driver.AppleHIDKeyboard   181
com.apple.driver.AppleMultitouchDriver  304.9
com.apple.driver.AppleHIDTransport  5
com.apple.driver.AppleHSSPIHIDDriver    41.6
com.apple.driver.AppleThunderboltNHI    4.0.4
com.apple.iokit.IOThunderboltFamily 5.0.6
com.apple.iokit.IO80211Family   1101.24
com.apple.driver.mDNSOffloadUserClient  1.0.1b8
com.apple.iokit.IONetworkingFamily  3.2
com.apple.driver.corecapture    1.0.4
com.apple.driver.AppleHSSPISupport  41.6
com.apple.driver.AppleIntelLpssSpiController    2.0.57
com.apple.driver.AppleIntelLpssGspi 2.0.57
com.apple.driver.usb.AppleUSBXHCIPCI    1.0.1
com.apple.driver.usb.AppleUSBXHCI   1.0.1
com.apple.driver.AppleIntelLpssDmac 2.0.57
com.apple.iokit.IOUSBFamily 900.4.1
com.apple.iokit.IOUSBHostFamily 1.0.1
com.apple.driver.AppleUSBHostMergeProperties    1.0.1
com.apple.driver.AppleEFINVRAM  2.0
com.apple.driver.AppleEFIRuntime    2.0
com.apple.iokit.IOHIDFamily 2.0.0
com.apple.iokit.IOSMBusFamily   1.1
com.apple.security.sandbox  300.0
com.apple.kext.AppleMatch   1.0.0d1
com.apple.driver.AppleKeyStore  2
com.apple.driver.AppleMobileFileIntegrity   1.0.5
com.apple.driver.AppleCredentialManager 1.0
com.apple.driver.DiskImages 415
com.apple.iokit.IOStorageFamily 2.1
com.apple.iokit.IOReportFamily  31
com.apple.driver.AppleFDEKeyStore   28.30
com.apple.driver.AppleACPIPlatform  4.0
com.apple.iokit.IOPCIFamily 2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.Libm  1
com.apple.kec.pthread   1
com.apple.kec.corecrypto    1.0
Model: MacBookPro12,1, BootROM MBP121.0167.B14, 2 processors, Intel Core i5, 2,9 GHz, 16 GB, SMC 2.28f7
Graphics: Intel Iris Graphics 6100, Intel Iris Graphics 6100, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1867 MHz, 0x02FE, 0x4544464232333241314D412D4A442D460000
Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1867 MHz, 0x02FE, 0x4544464232333241314D412D4A442D460000
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x133), Broadcom BCM43xx 1.0 (7.21.94.29.1a4)
Bluetooth: Version 4.4.2f1 16391, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
Serial ATA Device: APPLE SSD SM0512G, 500,28 GB
USB Device: USB 3.0 Bus
USB Device: Bluetooth USB Host Controller
USB Device: Hub
USB Device: USB-PS/2 Optical Mouse
USB Device: Ext HDD 1021
Thunderbolt Bus: MacBook Pro, Apple Inc., 27.1
  • Same issues - started happening a few months ago. BT always works fine after a restart, but when coming back from sleep it is catatonic or sometimes "not avaliable". The latter sometimes fixes itself after sleep/wake, but the only consistent fix is rebooting. ¯\_(ツ)_/¯ – w00t Aug 17 '18 at 12:02
3

Same model, similar issues - though I wasn't getting kernel crashing, but occasionally get non-responsive bluetooth after wake from sleep. An alternative workaround to restarting is to force quit the blued process. This can be done either through Activity Monitor or on commandline killall blued.

2

I finally figured out the solution. Some bluetooth modules in the 2015 Macs have actual hardware problems. To confirm this, I ordered a replacement 2015 bluetooth module for my MBP 2015 from iFixit. My Mac kept crashing upon waking up from sleep delivering the same kernel panic message the OP had regardless of whether i put in the original 22015 BT module - or the replacement 2015 BT module from iFixit.

My friend gave me her bluetooth module from her 2013 MBP which looks physically different but still fits just fine in the 2015 MBP. I plugged it in and haven't had a single BT issue for nearly a week. Hope this helps. A 2013 MBP BT module is about $70 on eBay or iFixit.

This problem was extremely annoying and it seems multiple 2015 MBPs have it. I bought this 2015 model from my school in 2018 brand new(Apple shipped it to my school) - and it had the problem from day one. Shame on Apple for selling broken hardware 3 years after the fact.

1

I reset the SMC once more and changed the Wi-Fi to 802.11n on 5Ghz, after reading that it could cause interference. This seems to have fixed the problems so far.

1

Mid-2015 15" with the same problem on High Sierra.

My observations and solution:

  • It only happens when I have shut the machine off and then started it (not on restart or on wake from sleep).

  • Fix is to reset the SMC, sometimes have to do it twice.

Super annoying.

1

Finally I found someone else with this issue! This has been quite a problem.

I've worked around the "Bluetooth Not Available" thus far by doing the following:

  • Downloading "Bluetooth Explorer" from Apple's site (can't recall where but it was not easy to find)
  • When the problem occurs, open it, choose Tools > Get Local Device Info, then clicking "Re-Enumerate USB Device" until it comes back.

Have just had to deal with it crashing every time I let it go to sleep for an extended period of time. Seems to be more problematic when it's on battery but also happens sometimes when plugged in.

I'm not allowed to ask him directly for some dumb reason, but if the person given best answer could elaborate on how exactly to switch that Wi-Fi setting that'd be awesome. If it's on the router side unfortunately that won't help me, as I'm at a college campus.

  • Hi! Yes, unfortunately that is a setting on the router side. You cannot change this on a client. I've never found the reason for this issue with 100% certainty tbh. But I have a hunch that it also had something to do with waking up when an external display was connected. I've since moved on to a new external display, and never ran into the issue anymore. More than that I don't know unfortunately :(. – wvteijlingen Dec 2 '18 at 17:54
  • Yeah I have an external monitor as well and seem to have more issues when working with that. Mine was an HP VH240a, so maybe related? Not sure. Occasionally I've had other problems with displays, one which scared me as it went black and wouldn't fire up at all without several SMC resets. Resetting the SMC a few times seems to help my issues somewhat, but not fix the problem fully. Annoying, as I just bought that monitor... – edude123 Dec 5 '18 at 19:03
1

Okay I found a way to fix the sleep-crashing issues:

Simply turn off Bluetooth before putting your computer to sleep.

Kinda annoying, but haven't had any problems since!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .