5

Since upgrading to El Capitan my spaces previews sometimes are text only, and sometimes are full image previews. It seems to be related to whether or not I initiate Mission Control on a space that is fullscreened or not.

Is there a way to force spaces to always use a preview picture?

Desired:

Sometimes occurring:

1
  • The area auto expands when you mouse over it. There may be a terminal command to set it permanently.
    – bjbk
    Oct 29, 2015 at 18:31

3 Answers 3

1

My two-part solution leverages Better Touch Tool + FunctionFlip:

Part 1 - Trackpad:

1) Go to system prefs -> trackpad -> more gestures -> uncheck mission control (effectively disabling the mission control gesture if it was enabled).

2) Download and install Better Touch Tool, open it, and go to trackpads to set up a gesture rule that uses the mission control + immediate preview action they made especially for all unhappy people (means no mouse hacks needed as mentioned in a previous answer). Don't forget to go to basic settings and set BTT to launch on startup as well. Here's a screenshot: screenshot of better touch tool

Part 2 - Keyboard

(assumes you already have BTT installed:

1) Download and install FunctionFlip, enable it in accessibility, then open system prefs - function flip - check F3, click the "start FunctionFlip" button, check the "start functionflip at startup" checkbox.

2) Go to BTT - keyboard - make a new keyboard shortcut using your now specially exposed F3 key and the same "mission control & immediately show desktop preview" option used in Part 1 above.

Hope this helps!

0
  1. In System Preferences, uncheck the Trackpad gesture for Mission Control.

  2. In BetterTouchTool, go to the Trackpad tab, and select a Touchpad gesture you want to trigger Mission Control. I use a Four Finger Swipe Down, but it can be whatever you're comfortable with.

  3. Hit the Attach Additional Action, and you want to daisy chain these actions: Save Current Mouse Position, Delay Next Action (for .09 seconds), Move Mouse To X:50.00 Y:0.00, Restore Saved Mouse Position.

Source: https://www.reddit.com/r/osx/comments/3owbrl/el_capitans_mission_control_how_to_always_show/

1
  • That works by mousing over the text versions, but changes mouse position and requires an extra application. Thanks for the well documented suggestion, but more intrusive for me than the text-only spaces.
    – RobW
    Oct 29, 2015 at 20:00
0

There seems to be a quite simple solution to this problem, and it works with all MacOS versions up to Ventura.

  1. Display the spaces

  2. add more empty spaces with the + button that appears, if you go to the top far right of the spaces preview bar

  3. you have to add enough empty spaces, so that the total number of spaces is large enough for the preview bar to be always immediately shown

On my new MacBook Pro I have to have at least 14 spaces in total to get this behaviour. On my old MacBook Pro I needed 12. So it seems to be related to screen resolution or maybe something else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .