1

How do I make Siri send text messages to a preferred address?

I & someone else both have iPhones, and the other person often uses Siri to send text messages to me. I generally send text messages to them using my iPhone. Sometimes, however, I will use my Apple ID to send the message using the Messages app on my Mac (OS X 10.8.5), as it is often more convenient to type or send images from a personal computer than on a phone.

The problem is that when the other person tells Siri to send me a text message, it will send it to whichever address I sent a message from last. This is problematic, since I will often not see a message until significantly later, as I am often not at my computer.

Is there a way to configure the person's iPhone to have Siri only send messages to my phone? If not, is there a different solution I could use (short of not using my computer to send the message) to prevent this situation?

  • 1
    You should be able to see no matter what device you use if you set up things correctly. What do your preferences for Messages show you can be reached at? (don't tell us private information, but rather, do you see you phone number and preferred email listed? This applies to iOS and to Mac. – bjbk Oct 29 '15 at 17:34
  • Per my comment to your answer, I do see my preferred email listed, but I do not see my phone number. – M. Justin Oct 29 '15 at 17:53
  • See the support article referenced: If your phone number is missing from your Mac - I'll update the answer – bjbk Oct 29 '15 at 17:57
1

These settings can be harmonized so that no matter how the sender responds, you receive your message on any of your devices including your Mac.

For complete details on setting up Messages for all your devices, see this Apple Support article.

iOS - Settings

  • Go to Settings in iOS and select Messages
  • Scroll to the Send & Receive setting and select it (tap)
  • Here you can add email addresses associated with your Apple ID

Mac Settings

  • Open Messages app
  • Select Preferences... from the Messages Menu
  • Under the Accounts tab, add email addresses where you can be reached at on your Mac

If your phone number is missing:

If your phone number is missing from your Mac Sign out of iMessage and FaceTime on your Mac:

  • Go to Messages > Preferences > Accounts.
  • Click iMessage in the left column, then click Sign Out.
  • Go to FaceTime > Preferences.
  • Select your Apple ID, then click Sign Out.

Sign back in to iMessage and FaceTime on your Mac:

  • Go to Messages > Preferences > Accounts. Click iMessage in the left column, then enter your Apple ID and Password to sign in.
  • Go to FaceTime, then enter your Apple ID and password to sign in.

With these properly set, you should be able to see and respond to messages no matter what account they are sent to. Siri will not even notice a difference.

Accounts Preferences

  • My phone number is not listed under the "You can be reached for messages at" section. I did discover that my Apple ID only had my phone number as daytime/evening phone, but adding the mobile number didn't fix that, unless there's some delay I'm unaware of. – M. Justin Oct 29 '15 at 17:53
  • The support article referenced in my answer will help you there: If your phone number is missing from your Mac – bjbk Oct 29 '15 at 17:56
  • Thanks. I followed the instructions there where I tapped "Use your Apple ID for iMessage" under "Messages > Send & Receive" in the Settings app. That did give me the option to check my phone number in the Mac Messages app (which I don't want to check, since I don't want my regular text messages sent to my computer). However, this didn't solve my primary problem, as I am still receiving the messages on my Mac only, and not on my phone. – M. Justin Oct 29 '15 at 18:24
1

Not directly. Siri just uses the contacts app, and when you send a message to a contact - iMessage is preferred.

You could edit those contacts to only have the SMS number or make a "shadow" contact changing one of the person's name to SMS and only include their phone number.

For instance if you texted me, you could make my first name SMS and my last name mike. "Siri - send a message to SMS mike" should work to pick that method of delivery if you didn't mind the setup work and the cognitive load of remembering to prefix/append a contact's name as SMS.

  • Unless I am mistaken, the OP says he is having the problem with the sender's device. This would be difficult to implement with all his contacts. I think the issue can be solved on his end where he has control. Then it matters not how Siri responds on the other party's device. – bjbk Oct 29 '15 at 18:11
  • @bjbk Yes - it's quite tedious and doesn't scale. But it's the only option I see and I know people that have implemented that not only for iMessages but to use siri to better choose work vs home addresses in some instances. The messages app just isn't currently programmed to do what is being asked of it in this case – bmike Oct 29 '15 at 18:12
  • Good point. Thanks. Do you think I should change or delete my answer? – bjbk Oct 29 '15 at 18:15
  • @bjbk No way! leave it up - even wrong answers help. It's not wrong and helps with learning. +1 by me – bmike Oct 29 '15 at 18:18
  • I will have to check with the other person when they're present so we can try on their iPhone, but I believe when I looked into this option previously, the problem was that since it was sent as an iMessage, the iPhone knew that the Messages message was from me. In other words, it didn't look like altering the contacts would help. That said, I'll give it a shot next time I have access to their device. – M. Justin Oct 29 '15 at 18:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .