5

I have my iPhone setup to open Photos app when I connect my iPhone to my Macbook Pro. I also have Dropbox automatically importing my photos when connected too.

Dropbox has no problems importing my photos, but Photos does. I can see my iPhone connected, but I can't see any photos on my iPhone as you can see from this image: (The name "Hold Me, Touch Me" is a reference to movie "The Producers" with Zero Mostel.). As you can see, the name of my iPhone shows up, but not the 168 pictures on the phone.

I suspect there is some [i]security setting[/i] where I have to tell Photos it has permission to read my iPhone, but I can't seem to find it.

[enter image description here]

  • I suspect that you can't have two simultaneous import operations. The Photos apps may not be able to access the iPhone while Dropbox is accessing the iPhone. Have you tried disconnecting and reconnecting the iPhone after the desktop Dropbox import completes? If you enabled iCloud Photo Library on your Mac and iOS device, your photos might already be on your computer. In which case, there is nothing to import. – Khürt Williams Oct 29 '15 at 16:16
  • Have you tried using Image Capture? Personally I am not sure why you are doing this. You are using up twice the space on your HD. One copy in the Dropbox folder and another in Photos. If you simply want a copy in Dropbox using the Camera Upload feature of the Dropbox mobile app. – Khürt Williams Oct 29 '15 at 16:16
  • Dropbox and Photos both accessing could be the issue. I'll shut off Dropbox and see if that helps. – David W. Oct 29 '15 at 20:42
  • @KhürtWilliams Yes, I know I'm doubling space, but it's temporary until I get this issue fixed. My preference is to store my photos in iCloud and then I wouldn't have to transfer photos between my devices. However, my Photo library got corrupted, and I have dozens of duplicates and all the faces in the Face database got added as pictures too. If I turn on iCloud and Photo Stream, I fill up my iPhone with garbage. I need to clean up the database. – David W. Oct 29 '15 at 20:44
  • @KhürtWilliams Turning off Dropbox syncing does nothing. iPhone photos aren't showing up. – David W. Oct 30 '15 at 16:43
3

When I plugged in my iPhone this morning, it asked me if I wanted to share my photos with this device (meaning my computer). I clicked on "Yes", and the problem was solved.

I thought the problem may be one where my iPhone didn't trust my computer to share the photos, but I couldn't find anything on the iPhone or my Mac. I checked iTunes too, but didn't see anything.

Once I gave my Mac permission to see my photos and everything is now fine.

  • This worked, but I had to unlock the phone's screen for the question - whether to trust this computer - to pop up. – darklon Jun 19 '16 at 7:53
3

I discovered this problem after upgrading to High Sierra. My iPhone was containing 94 photos. I don't use Dropbox nor iCloud, just the original USB cable (in a perfect state).

I plugged my iPhone on my MacBook Pro and I opened Photos. My iPhone is fully recognized: I gave it a name so as to avoid to confuse between all my family's iPhones. When I selected my iPhone below the Devices menu, the window of Photos stayed empty.

There wasn't any error message within /var/log/system.log.

Here is a receipe which worked in my case:

  1. Quit Photos
  2. Open iTunes
  3. Select the iPhone
  4. Eject it
  5. Unplug the iPhone (its USB cable)
  6. Quit iTunes
  7. Plug the iPhone back (its USB cable)
  8. Open Photos

Then I saw all my iPhone 94 photos within Photos.

I suspect this little bug is caused by the asynchronous nature of the synchronisation mechanisms between iPhone and Mac and the lack of eject button within Photos.

Many users might be unplugging their iPhone just when one of the synchronisation agent is running, thus letting the iPhone as still connected. A sort of ghost iPhone from the MacOS point of vue. The trick with iTunes is a way to unplug it cleanly from the MacOS point of vue.

  • This worked for me. – msouth Jun 23 '18 at 13:55
1

I had the same problem: iPhone showed up but photos on the did not. I restarted the iPhone but the problem was still there. I then restarted the iMac and when Photos app opened it was back to normal.

Note that I am not using iCloud for photos.

-2

I have the exact same problem EXCEPT that I selected "never for this device" for Dropbox. This worked perfectly until today. Two days ago, I upgraded to El Capitan. Thatʻs the only thing Iʻve done differently since it worked properly last time.

-2

It finally worked for me, after I went on to the APP STORE, checked for updates, and updated my MAC to 10.11.1

You must log in to answer this question.

protected by Community Nov 10 '15 at 17:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .