2

I've been searching around on the internet for a while trying to answer this question, but I can't get a clear answer for it.

Background info: I'm running El Capitan with a Windows 10 partition on my MBP that I created through Boot Camp. When I ran the boot camp assistant, I made sure the "Download latest support software from apple" box was checked. After that my computer rebooted and I installed Windows onto the newly created partition from a USB drive. I then booted into Windows, where an Installer for the Boot Camp Windows Software popped up. I installed it.

I've read on the internet that the Boot Camp Support Software allows read-only access to the Macintosh HFS+ partition, BUT windows does not recognize the partition, I can't even read from it. Why is this? Is what I read wrong? Or is there a different thing I need to install that's not the software apple put on my Windows Install USB? Or is this feature simply not supported in Windows 10?

I can't figure out why this drive is not accessible to me even though a bunch of places on the internet say that support is included in the Boot Camp Support Software, which I'm fairly sure I installed

EDIT: I realize that there are other third party options to get both read and write support for HFS+, but I am specifically looking for an option built in by Apple.

  • I installed the support software that Bootcamp Assistant downloaded and I got read-only access to my Macintosh partition. However, I did need to assign the partition a letter via the Disk Management utility in Windows. – Dempa Oct 28 '15 at 23:33
  • I looked into that but my disk management software doesn't allow me assign a letter to the drive, it doesn't even recognize it. Maybe I should try reinstalling the software. – Joshua French Oct 28 '15 at 23:51
  • Out of interest, was it on windows 10? – Joshua French Oct 29 '15 at 0:05
  • Yes, it was on Windows 10 – Dempa Oct 29 '15 at 8:39
2

I finally solved it!

This literally took hours out of my day, but I now know what the problem was. It turned out that the drivers actually were installed. by verified this checking for the presence of the following files:

C:\Windows\System32\Drivers\AppleHFS.sys
C:\Windows\System32\Drivers\AppleMNT.sys

The reason that the drive was unreadable is because they were encrypted with FileVault. I disabled FileVault in OS X, and when I booted into Windows again, the partition was mounted.

There might be a way to use FileVault and Boot Camp together, I'm not sure. I read in a few places, however, that if you enable FileVault after installing Windows with Boot Camp, you can have your drive encrypted and accessible from windows. (This is just a hunch however, I'll have to look into it more)

  • 1
    This did not help me, I don't use FileVault. – Chef Pharaoh Oct 5 '16 at 16:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .