I'm trying to export a Developer certificate from Keychain Access. I've followed all the instructions and got to the point where I need to enter the "login" keychain password.

However, when I enter this password and press Allow, nothing happens.

I've checked the password multiple times. The Keychain Access is set to Keychains = login and Category = My Certificates. I've tried with other categories too.

  • It's definitely password typo. Check input language probably? Also, keep in mind, that keychain password is not alway equal to you administrator password. If you logged in from different user or exported keychain from somewhere else - the passwords may not match – Petro Korienev Oct 28 '15 at 9:25
  • 1
    But I can open and lock the login keychain using the same password. Can it be a different password than that? – Mikael Gyth Oct 28 '15 at 9:40
  • No, if you're locking and unlocking keychain - the password fits. Strange then – Petro Korienev Oct 28 '15 at 9:43

I had the same problem when logged in via VNC / remote desktop - it appears that if your mac detects a 'security risk' it will prevent you from pressing the "Always Allow" / "Allow" buttons.

No error message is shown and the box doesn't shake (although the button does highlight blue when clicked.)

The same issue seems to exist with KVM programs such as Synergy.

To solve the problem, simply log in to your mac using a physical keyboard and mouse, ensure remote desktop / KVM connections are turned off and try clicking the "Allow" button again

  • 1
  • This resolved my issue. I was using Sharemouse for input to the Mac. – Mikael Gyth Nov 9 '15 at 7:22
  • You will need to also restart your machine after disconnecting the VNC session (El Capitan 10.11.1) – iTris Nov 11 '15 at 15:46
  • Oh weird - mine worked straight away :) YMMV I guess – Nathan Dunn Nov 11 '15 at 22:50
  • 2
    Very Important Point from Nathan's post: The plugin's MagicPref's & SmoothMouse will trigger the same security mechanism - quit them and try again. Hopefully this helps someone! – Moe Nov 22 '15 at 15:35

For me, I had to go to System Preferences -> Security & Firewall -> Privacy.

On the left, click on Accessibility, then on the right side uncheck every checkbox. This resolves the problem. For me, I had Steam (from VALVe) running and Karabiner (keyboard key editor) which also was allowed to control the computer.

  • I'm using synergy and have done same things in Privacy, but didn't receive right to press Allow. Probably I need a couple of reboots – Victor Perov Mar 17 '16 at 11:04

Not the answer you're looking for? Browse other questions tagged .