3

Google account issue

I cannot login with my Google account on El Capitan (OS X 10.11.1). It accepts my mail, password and 2FA verification code too (Google Authenticator).

After pressing the last Enter, the login window turns grey and nothing happens (no feedback, no spinning wheel etc.)

I've left it for an hour without doing anything else, but still the same.

iCloud issue

The other account I am having issues with is iCloud. iCloud is signed in (my Clear to-do list which uses iCloud for sync is syncing as usual.

However, when I go to System Preferences > Internet Accounts > iCloud, opens for a few seconds than locks itself.

After entering my password it unlocks for a second, than "locks" again (the checkboxes become gray and unchangeable).

I'm also unable to change AirDrop to Contacts Only from Everybody. Previously AirDrop had the No One status and when I tried to change it asked for my iCloud password, but didn't change after entering.

Facebook and Twitter accounts are both logged in with no problem on my Mac. Furthermore, I can access both my Google and iCloud account through web browser.

  • Regarding the Google account login issue, I hope my answer to this related question may provide a solution: apple.stackexchange.com/a/226577/132829 – Aaron Feb 7 '16 at 15:03
  • I'm sorry that I didn't close this case. My problem solved itself without any sign or explanation so I cannot share my answer. Maybe it just needed some time. How can I close this question? – Barnabas Makkay Feb 7 '16 at 18:03
  • You may remove it, or flag to be safe. – Daniel Springer Apr 25 '16 at 23:47
1

I'm certainly no expert on iCloud, but I recently had some luck by using the code (as opposed to the password) from my mobile device. You might try that. While it may not fix it, it may give you a more helpful error. That is what happened for me.

  • What do you mean by code exactly? I think I have a verification code or something for iCloud too, but it's only needed when you authenticate your device first. – Barnabas Makkay Oct 27 '15 at 18:13
1

This issue still stuck me and I tried solutions given:

Can't login with Google using Internet Accounts

macOS Sierra Internet Accounts Google login stuck

All of them not work for me, e.g., delete auth, login/out, close 2 step authentication etc.

Finally, I updated to MacOS High Sierra 10.13.6, the issue disappears.

So I leave a note here for people maybe encounter the same issue in 2018. Just Upgrade.

0

Try signing out of iCloud and then adding the Google accounts. None of the steps mentioned on any forum worked for me, but this did the trick.

  • Log out of iCloud account
  • Add Google Account(s)
  • Log back into iCloud

Let me know if this works for you.

  • Thanks for sharing it. In my case the problem magically disappeared and I could log in, so I can't test your solution. – Barnabas Makkay Feb 17 '17 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .