4

For the past couple of weeks, a process identified as usernoted appeared to "take over" my machine after a few hours of use, eating over 99% of available CPU.

Force quitting the process doesn't help; only a system restart puts usernoted to sleep for a while.

What is this process and how do I get it under control?

I am running OS X 10.10.5 (build 14F1021).

  • 1
    A search on Google reveals that some have had this issue with the Bark app or even with Growl. Do you have one of these types of apps installed? – bjbk Oct 27 '15 at 14:55
  • As mentioned, Bark appears to be a potential culprit, according to Apple Support forums. The usernoted high CPU usage has also been noted on the Wunderlist forums as a recent issue. Do you have Wunderlist installed on your Mac? – AruAkise Oct 27 '15 at 15:29
  • I do have Growl, but not Bark or Wunderlist. And I haven't actually used Growl in months, so it hasn't been running. – Dan Oct 27 '15 at 17:41
7

Usernoted is a process that is responsible for notifications on OS X.

The instructions from this post solved usernoted sitting at 100% CPU on my Mac, even though they were intended to only fix stuck Notification settings:

  1. Open the Library folder in your Home folder.
  2. In the Library folder, open the Application Support folder.
  3. Locate the folder named NotificationCenter. Drag this folder to the desktop.
  4. Next, open the Terminal application. Copy and paste each line of these commands into the Terminal window, in order. Press return after each line:

    cd `getconf DARWIN_USER_DIR`
    rm -rf com.apple.notificationcenter
    killall usernoted; killall NotificationCenter
    
  5. Close the Terminal app.

  6. Restart your computer.

For me, the problem started after I had upgraded from Yosemite to El Capitan: usernoted was constantly sitting at 100% CPU and nothing I tried (force-quitting usernoted, checking if Growl or Bark are installed, booting into safe mode, SMC reset, running all the maintenance and cleaning scripts in Onynx, etc.) seemed to help until I tried the steps listed above.

0

While this may be related to Growl or one of the other notification apps. This seems like it could be a solution:

https://discussions.apple.com/thread/4926305?tstart=0

0

I had same problem, at last, I found that it was because of Webpack I'm using in a frontend project. Webpack is a command line tool. Many terminal-notifier processes are consuming much CPU resources.

Once I quit Webpack, usernoted exits, and CPU become quiet!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .