I'm having a problem with the fonts on Mac OS X 10.10. I don't remember if I had this problem when I used 10.9, but I have it for more than a month now on 10.10.

So, in some applications, some groups of letters are being replaced by symbols: i.e. "fi" is replaced by a dot in Adium, and on Airmail 2 is replaced by a weirdly placed "e".

Here's a print form Adium:


The actual text is: test: FIGARO figaro

And a print from Airmail 2:


There are more combinations of letters changing to different symbols, but I can't remember them right now.

Can somebody please tell me why is this happening? Thanks in advance!

  • I don't know why this is happening, but that seems to be a problem in some way pertaining to ligatures, the single characters which dynamically replace certain letter combinations to improve spacing. The most common ones are ff, fl, fi, ffi and ffl. – Timothy Mueller-Harder Oct 27 '15 at 14:11
  • @timothymh You're right, here's another test in Adium: i.imgur.com/xn8K9wj.png – Gecko Oct 27 '15 at 14:45

I would hazard that some fonts on your system have gotten duplicated or corrupted. Here's how to deal with that:

  1. Open Font Book.
  2. Click "All Fonts" in the sidebar.
  3. Type L or select Edit > Look for Enabled Duplicates…
  4. Let it resolve any duplicates it finds.
  5. Click in the column with the font list and type A or select Edit > Select All.
  6. Select File > Validate Font.
  7. When it finishes, follow any recommendations regarding disabling or removing fonts.
  8. Reboot your computer (might not need it, but it's good to be safe).
  • We kinda posted at the same time. I figured it out by myself, finally, but thanks for your contribution nevertheless. BTW, no need for a reboot, everything updated in real time on every app I was having problems with. – Gecko Oct 27 '15 at 17:08
  • Ah, so I see! Glad to hear it's worked out. Could you mark this as the accepted answer for Googlers in the future with the same problem? :) – Timothy Mueller-Harder Oct 27 '15 at 17:10

I've solved the problem myself. I've installed a lot of fonts some time ago and some of them had already been installed by default, by OS X, and this created some conflicts which, apparently, caused my problem.

Hope it helps somebody else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .