5

I can connect to my iPhone hotspot through Wi-Fi on my MacBook Air, but when I then click "Disconnect from my iPhone" in the Wi-Fi menu, nothing happens.

The only method I could use disconnect is to disable Personal Hotspot on the iPhone itself.

Disconnecting on my MacBook used to work prior to upgrading to OS X 10.11, El Capitan. Any idea of a fix?

  • I have this same problem, although I'm not sure how to fix it beside disconnecting the hotspot from the source. (i.e. iphone,etc.) – user154579 Oct 27 '15 at 19:04
  • 1
    Hmm - sounds like a temporary block. Is this reproducible after you reboot your Mac? – bmike Oct 27 '15 at 19:34
  • Actually, this did not help on the long term. I ended up turning off wifi on my mac for a while when I want to disconnect. – Ben2209 Jul 7 '16 at 5:42
-1

My solution is to "Turn Wi-Fi off" and the enable it again, on the MacBook. Kinda hassle but it solved my issue.

  • 1
    Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Jul 6 '16 at 20:37
  • following this answer clearly resolves the problem. – frumbert Jul 18 '16 at 6:04
2

I solved my problem following bmike's instructions: I rebooted my computer!

  • 1
    Actually, this did not really solve the problem. So I always turn off wifi for a while on my mac. So far I have not found a better solution – Ben2209 Jul 7 '16 at 5:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .