1

I'm using OS X El Capitan (10.11) on my MacBook Pro (Retina, 15-inch, Early 2013) and I'm trying to use System Preferences -> Sharing -> Internet Sharing feature and something isn't working...

I made sure that Share your connection from... is set to Wi-Fi as that's my source of internet, and To computers using... is set to Thunderbolt Ethernet as that's where my Raspberry Pi is plugged in via crossover ethernet cable.

I'm not seeing any IP address assigned via Network Utility on Thunderbolt Ethernet (not 100% sure if it should, but I'd assume it should).

Any help?

1

Apple Network Sharing is very unreliable across different OS and different network channels. I've lost a lot of time on this. Enough so that I'd suggest getting a simple good quality router and setting it up to pick up the wifi ethernet and redistribute it via ethernet. Make sure to set the access point router to act as a bridge (i.e. it would continue to obtain DHCP addresses from the central router). That way you can share to other devices on the master network.

You may find you get faster and more reliable internet on your MacBook Pro as well as the aluminum hulls are not particularly reception friendly, especially in comparison with a router with proper antennas which can be positioned as you like.

I'm doing something similar but using powerline adapters (more reliable than wifi) to bring the internet to the access point router.

  • 4
    Dear downvoters if you don't have useful answers on this topic, you shouldn't be downvoting the one above. I've spent tens of hours trying to solve and document internet sharing issues with Apple OS. Internet sharing does not work reliably. It's a dead end: I'm only guilty of trying to save other AskDifferent members from falling down the same rabbit hole. – Foliovision Apr 15 '16 at 20:45
  • Downvoted as this is not an answer to the question. No suggestions on what the problem might be or how to even begin diagnosing it. It is simply an instruction to "do something else". Just my 5 cents – user3728501 Dec 14 '19 at 16:10
0

I don't know if this will work universally, however I solved the problem in the following way.

On Mac OS X Machine

  • Ethernet -> Configure IP v4 OFF
  • Wifi connected to AP with relevant settings
  • Sharing -> Internet sharing ON WIFI to ETHERNET
  • Terminal -> ifconfig -> Should now see "bridge100" device, with address something like 192.168.2.1, probably not particularly relevant since this is self assigned by OS X

On Linux Machine

  • Configure ethernet, leave in DHCP mode

Should just work. Issue for me was that I left the ethernet connection with a DHCP assigned IPv4 under 'network settings', rather than disabling it. For some reason that interferes with the settings from 'sharing'. I guess because the OS tries to assign values for 2 different interfaces on the same ethernet device. Disabling IPv4 configuration in 'Network' fixed the issue. This may not work for everyone, as others may have a different underlying problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .