0

I recently converted to OS X(10.10.5) from Linux Mint. I used spaces there and that worked perfect. Now on OS X the following happens, which I just cannot get used to:

  1. I have multiple spaces. Let's assume I am working in the second space and have the browser open
  2. I scroll down to the doc bar to open the terminal

Result: The OS automatically switch to the other space and opens the Terminal app there, so I cannot see the browser and the terminal app together in the same space. On Linux Mint it is simple. Whatever you open appears in the space you are working in at the time.

0

Same on OS X - unless you have an app specifically assigned to a Space.

Check what you have set for each app by right-clicking it in the dock…

enter image description here

  • All Desktops - the app will follow you wherever you go
  • This Desktop - will change to show the Space number once assigned, then will always open in that Space.
  • None - will open in whatever Space you're in at the time.

After comments:-
If you have Mission Control set to 'Displays have separate Spaces'& 2 monitors, you will need a minimum of 3 Spaces before these options will become available to you.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .