6

iPad and iPhone think they're in a different country. All ads and searches default to Hong Kong.

I have checked my location setting on each device and they're set for Australia and I've cleared the history in Safari as suggested elsewhere but no change to the searches and ads. Help required.

  • 1
    You could move from Aussie land to HK... just jokes. – Deesbek Oct 23 '15 at 1:07
  • Droll. Almost funny.....can you improve on that? – Andrew Oct 23 '15 at 4:58
  • 1
    Try connecting to a different WiFi/ISP - local Starbucks etc. I "moved" from London to Bristol for a week after my ISP changed my external IP address. – Tetsujin Oct 23 '15 at 7:25
  • I'll give that a go, but one would think that logging in at home should change that too but it doesn't. I've also tried the other fixes suggested in this and other fora with no luck. Last resort and still waiting was to report it to Google. I log in to airport lounge WiFi on a weekly basis and that has no impact. – Andrew Oct 24 '15 at 22:23
1

Have you checked the DNS setting (in ios) for your wifi access point at home? Don't have access to my phone at the moment but I think it's Settings > WiFi > (your wifi) > advanced (look for the words DNS or URL somewhere)

Sometimes apps suggest putting in a custom url in there, and they essentially work as a proxy. Want to make sure to delete those if there's something in there. I suggest you try connecting at a coffee shop or a friend's wifi to see if the behavior changes. Make sure VPN is off/disabled too.

On a different tack, it could be how your router is configured, since you're saying the same thing is happening on two separate ios devices. Be good to get in the router and look around, or ask whoever manages the router.

  • I've sorted this one out, I was using Onavo for VPN. They were the culprit so I've deleted the profile and the app. Problem gone. – Andrew Nov 2 '15 at 21:54
1

I've sorted this one out, I was using Onavo for VPN. They were the culprit so I've deleted the profile and the app. Problem gone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .