2

After upgrading to El Capitan I get an initial login screen with my name and round icon, which wants my iCloud password. After that I get the username and password screen, where I enter my local username and password.

I want to just enter my local username and password. Is there a way to disable the iCloud login? I seem to recall selecting something related to that when installing, but I don't see anything about it in my login preferences.

  • Could you upload an image of the request? (blur out the personal details if needed). If you are getting a skippable prompt, there should be a "skip this" type blue text (by default) but if you already have your account tied with iCloud, you might need to log in with that account. Look in the users&groups preference pane for that detail... – bmike Oct 22 '15 at 20:49
  • The screenshots controls don't work on the login screen, but it's just the standard login screen. There are no skip options, and it has the icons for my user, and the guest account. – user153775 Oct 23 '15 at 1:10
1

It turns out the main issue is that I'm using FaultVault encryption. On restart, the login screen showing user photos is part of FileVault, and happens before booting OS X, so it doesn't utilize the login screen preferences.

When you simply logout, you're shown the actual OS X login screen, as the machine is already booted. That screen does utilize the preferences and appears as I expected.

0

This has never happened to me, but it seems to be as simple as turning off all iCloud-related services and logging out of all iCloud-enabled apps:

The solution is to go to System Preferences, iCloud and clear all the ticks so that you are no longer syncing anything to iCloud. You should also go into every Apple app (FaceTime, Calendar, Messages, iTunes, Reminders, Notes and any other app you can think of), check the preferences in each app and if you are signed in to iCloud then sign out.

After disabling all the iCloud sync options in System Preferences and every single Apple app, return to iCloud in System Preferences and tick all the boxes again to start syncing once more. You might also need to sign in again with FaceTime and the other apps you signed out of. I don’t think you need to restart the Mac, but try it if you still have problems.

Gleaned from this page.

  • Logging out of iCloud on everything fixed it, sort of.I now no longer have the double login screens, but the login options don't seem to have any effect. I have it set to show the username/password fields and to hide shutdown/restart, yet it shows the account icons and the shutdown/restart options. – user153775 Oct 23 '15 at 1:11
  • Actually, I have another clue... If I simply log out I get the login screen I expect: username and password. If I restart, I get the the version with user icons. – user153775 Oct 23 '15 at 1:15
  • Actually, I figured it out. With FileVault enabled, you can never have the plain username/password login screen. It always wants to show the authorized users in the icon form. apple.stackexchange.com/questions/158460/… – user153775 Oct 23 '15 at 1:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .