3

I have been using a TRENDnet TU-S9 USB to serial adapter for a couple years.

When I upgraded OSX from 10.10 Yosemite to 10.11 El Capitan, it stopped working.

I've tried reinstalling the driver, but that did not fix it.

I ran ioreg -p IOUSB and could still see the device, which is a good sign.

...    
+-o USB-Serial Controller D@14200000  <class AppleUSBDevice, id 0x100000533, registered, matched, active, busy 0 (6 ms), retain 11>
...

Unfortunately /dev does not contain tty.usbserial when my adapter is connected.

How do I get OSX to create /dev/tty.usbserial when I connect my adapter?

  • Best guess would be look/wait for an updated driver - always an issue with a major OS update... don't jump until you are certain all your esoterica has functional drivers. I can't use El Cap until my pro audio rig has updated drivers... or unless I don't want to earn a living in the meantime... – Tetsujin Oct 22 '15 at 19:39
3

Prolific has a new driver out that works with El Cap: http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41

  • Jan Lehnardt provided a working driver. Thank you, I have tested and confirmed running Mac OS 10.11.1 with zterm and alcatel switches. – user155482 Nov 2 '15 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .