When I try to drag Photos.app or certain other bundled system apps to the trash in El Capitan, I get the error

“Photos.app” can’t be modified or deleted because it’s required by OS X.

The solution in Yosemite would be simply to use

$ sudo rm -Rf Photos.app

but this method is blocked in El Capitan. You instead get

Operation not permitted

I tried to change permissions with

$ chflags -R nouchg Photos.app

to no avail.

There must be a way around this!

3 Answers 3


UPDATE: I have unselected my answer because an icon-less and half-working (see screenshot) enter image description hereversion of Photos.app appeared on my system and opened automatically on SD-card insert. This worked and did not cause problems for months, and now Photos is back 🙁

El Capitan has a new feature called System Integrity Protection. It does not allow the deletion of preinstalled apps. This link gives details for disabling it. The short of it is:

Restart and hold Command+R to go into recovery mode. Open "Terminal", found in the "Utilities menu" and use the commands

$ csrutil disable; reboot

to disable SIP and reboot. Now open Terminal.app normally and do

$ cd /Applications/
$ sudo rm -Rf Photos.app

and live happily ever after.

A few caveats: I don't know what SIP does specifically, but this post suggests you should at least re-enable it right away (and perhaps not disable it at all, ever). Go ahead and do that by using the command

$ csrutil enable; reboot

in Recovery mode (see above). I also don't know whether El Capitan has Photos.app-dependent system processes or not, so your mac may potentially not work the way you want it after this. I have protected myself by first Archiving Photos.app and leaving Photos.app.zip in /Applications/, but again, I don't even know if this is good enough. So proceed at your own peril!

Finally, this will work to get rid of any bundled system app (but the same or more severe warnings apply).

  • 1
    Thanks, but what would happen to the iCloud integration, or any system 'assumed' it to be exist and called it. Just an error alert or system crashed?
    – DazChong
    Commented Dec 18, 2015 at 1:26
  • 1
    Follow up: I did this on my system on Oct 21 and it still hasn't caused me any problems. I'm not an iCloud user. General warnings still apply though. Commented Jan 3, 2016 at 9:44
  • SIP does what it says: maintains the integrity of your core operating system. Disabling it (even briefly) opens up critical parts of the system to be modified (eg remove bloatware) but also allows the user to break the OS, prevent upgrades, etc and / or malware to insert itself into the system and remain undetected. So think twice! Definitely enable SIP as soon as you can. Commented Mar 7, 2018 at 10:03

Rather than removing the app, what I did was the following...

I disabled SIP (like Alejandro posted). Then I went into the applications folder, "Get Info" for the Photos app, then set the "Everyone" permissions to "No Access". This way, when anything is plugged in, the app will not launch (well it starts then stops) but the app remains in case you need to reenable it. Once that is done, reenable SIP.


Right click on "Photos" in "Applications" folder. Click "get Info". Change all permissions to "read and write". Drag Photos app to Trash.

This works for any stock apps by Mac OS.

  • 1
    I am the administrator of the machine, and yet it says I don't have necessary permissions to change the privileges.
    – hatmatrix
    Commented Jun 6, 2016 at 1:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .