4

I'm running OS X El Capitan, and have 3 Gmail accounts signed into it. For some reason, the Erase Junk Mail menu option is greyed out. How can I use this option?

enter image description here

  • 1
    Excellent question. Same issue on my mbp. Might have to do with Gmail <-> Apple Mail folder mappings. – Hoshts Oct 21 '15 at 22:27
4

Go to mail>preferences>junk mail>under when junk mail arrives make sure options #2 move it to the Junk mailbox is selected and this should fix your problem immediately.

Let me know if you need any help, this is what worked for me after I let my junk mail build up to over 600, which was killing me, I can understand you want it gone! Should look like this:

enter image description here

2

It looks like this option is disabled when Apple Mail is set to its default Junk settings.

One of the option groups in the settings panel for Junk is When junk mail arrives. By default it is set to Mark as junk mail, but leave in my inbox.

Changing this to Move it to the Junk mailbox activates the menu item you refer to.

1

This is a sign that Apple Mail's built-in junk mail filtering is turned off. Go into Preferences and select the Junk Mail tab in order to turn it back on again.

  • Actually, Apple Mail junk mail filtering is switched on already. Any other ideas? – Trevor Sullivan Oct 21 '15 at 19:35
  • I suggest you check out Hoshts's answer, it may well apply to your situation. – Alan Ralph Oct 22 '15 at 20:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .