3

I get basically the same error as described in the thread Can't backup iPhone 5s (iOS 8.4) using iTunes 12.3 (because an error occured) or iCloud backup using an iPhone 5 and iOS 9.0.2.

It can neither - backup to iCloud automatically when connected to WiFi and electricity while locked - backup to iCloud manually - backup to iTunes automatically - backup to iTunes manually

I have tried a lot but nothing seems to work so far, and I am hoping to get some input. Here is what I have done so far (unsuccessfully):

  • everything in this Apple support article, including rebooting both my MacBook and the iPhone as well as resetting the Lockdown folder
  • deleting the old Backup from ~/Library/Application Support/MobileSync/Backup hoping the iTunes backup would be built a-new from scratch
  • disabling and re-enabling iCloud backup from my iPhone as well as deleting the old Backup (which incidentally did not seem to work as it is still listed under "last backup" even after deletion)
  • the aforementioned thread lead me to search for 'null' or 'zombie' apps (without name) in settings -> general -> memory&iCloud usage – unfortunately, there are none

Any ideas how to fix this?

2

For anyone who happens to have the same problem: It turns out the database of the Whatsapp application seems to have been corrupted in some fashion. In order to see a live log for your iDevice, connect it to your Mac and open XCode. Under Window->Devices, there is a panel at the very bottom. When trying to backup unsuccessfully with iTunes, there where a lot of error messages, one of which read

<Warning>: ERROR: Backup error - open_dprotected_np error: Operation not permitted (1) at path "/var/mobile/Containers/Shared/AppGroup/BAB2BCE4-C114-410B-ABFE-8C6B140B9446/Library/Preferences/group.net.whatsapp.WhatsApp.shared.plist.YvjyOTy

I went ahead and uninstalled Whatsapp from the iPhone. After that, both iTunes and iCloud backups worked again.

  • The error I'm getting is: Feb 9 13:18:35 iPhone BackupAgent2[355] <Warning>: ERROR: Backup error - open_dprotected_np error: Operation not permitted (1) at path "/var/mobile/Library/Passes/.dat.nosync0082.rQEmei" (MBErrorDomain/100) I can't figure out how to resolve it though. – James Ward Feb 9 '16 at 20:20
  • Have you tried deleting everything from Wallet (formerly Passbook)? – PassfishSwordword Feb 11 '16 at 6:34
  • Yeah. Didn't work. – James Ward Feb 11 '16 at 16:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .