I'm a heavy user of OS X's / iOS's ‘text substitutions’ or text replacements. I probably have hundreds of these.

At some point in the recent-ish past (last couple of years?), Apple silently started syncing them between devices logged into the same iCloud app; that was great, for a while.

Unfortunately, at some point, my Macbook lost all of my substitutions, for no apparent reason. They still existed on all my iOS devices, but now none of my completions (like ccommand or ooption or sshrug) worked on my laptop. This eventually fixed itself (again for no apparent reason) … but it's just happened again, immediately after purchasing and setting up a new Mac Pro.

As this is the second time, I'm starting to wonder if anyone else has seen this behaviour, or if they know how to go about fixing it without waiting on iCloud to Magically Fix Itself, as I did last time?

  • 2
    I've this exact issue. I tried doing what was recommended on the Apple discussions, to delete the file from iCloud. This didn't help me, as now I cannot even create new ones. I hope you find a solutions, as this is extremely annoying. – At0mic Oct 20 '15 at 4:14
  • I had an issue with substitutions resyncing from iPhone to Mac after being deleted on the Mac. Making sure I deleted all versions worked for that. Hope you get a good answer on this one, as it would be good to know the source of [& cure for] these glitches. – Tetsujin Oct 20 '15 at 6:36
  • @IronCraftMan I'll self-answer later if I can reproduce; but after adding a new completion on my iOS device (where all the old ones were still showing up), all of them shortly re-sync'd to one of my machines … – ELLIOTTCABLE Oct 21 '15 at 4:01

After removing the folder com.apple.InputMethodKit.TextReplacementService from the depths of the ~/Library heirarchy and restarting the computers my current list of Text Replacement shortcuts is available on two Macs that previously refused to synchronize. Both of these Macs legitimately run Sierra, but didn’t start life that way. The folder com.apple.InputMethodKit.TextReplacementService is buried somewhere inside ~/Library. Sorry, I didn’t make note of the full path — I found it using a Finder Search.

Update: A friend in the Ars Technica: Macintoshian Achaia forum reports that the path is ~/Library/Group Containers/com.apple.InputMethodKit.TextReplacementService

A VooDoo fix for Macintosh Text Replacement Sync - Jeff Berg - Mini'app'les

  • Link to the OP? – ELLIOTTCABLE Dec 13 '16 at 22:27
  • I assume you meant a link to my original blog post from which this was clipped. Sorry, a stray character slipped into the URL and the link wasn't showing up. Fixed now. – jaberg Dec 14 '16 at 5:14

I noticed this as well, and after a year of being annoyed by it I managed to fix by "brute force" ;-) What worked for me is opening the relevant screens in latest iOS and OS X side by side, and typing the same values for each. I only use 5 or 6 shortcuts so it was easy. In the past I've updated the iOS OR the Mac device and my changes were overridden by the other. So this worked, give it a try.


So, this has happened to me twice more (up to four times now, Go Go Apple™! (。-_-。), and the same fix that solved this for me when originally asked has worked both times. I'm going to consider it an actual solution, at this point (although do please let me know if it works for you, as well!)

If you have another device from which they did not disappear (for example, an iPhone), then leave the settings entirely alone on your computer, and add a single new completion to your iOS device. With any luck, all of your old completions (along with the new one, of course) should magically appear on your desktop machine!

(Important to note, though, that you may find it difficult to remove substitutions, so don't make your entry something that will trouble you later if you can't remove it! I suggest something like ‘afwrdhd’, that you'll never actually be trying to type.)

  • This happened again to me last week. The fix I document above took about two days to ‘sync’, but again, it worked. Phew. – ELLIOTTCABLE Dec 8 '15 at 18:02

For me, this was caused by the operation of the Flycut application after establishing confirmation in its "Save forgotten items to Desktop:" menu. After deleting the confirmation, scan the text messages on the desktop.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .