I'm getting the following after about half an hour of Preparing Backup:

  • Setting security information: Operation not permitted
  • Error processing extended attributes: Input/output error Error moving - -- disk image from /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/com.apple.backupd.WpUkVn/iMac.tmp.sparsebundle to /Volumes/TimeMachine/iMac.sparsebun...
  • Failed to create disk image /Volumes/TimeMachine/iMac.sparsebundle, status: 512
  • Backup failed with error 20: 20
  • Network destination already mounted at: /Volumes/TimeMachine
  • statfs call failed, error: 2 No such file or directory

I had Time Machine working but now nothing. A few extra things:

  • I have completely formatted the partition.
  • I have tried deleting the Time Machine preference file.
  • I am using a router running Netatalk. I am aware that this is not a supported backup solution.

Thanks guys!

iMac (Retina 5K, 27-inch, Late 2014), OS X El Capitan (10.11)

1 Answer 1


I also use netatalk/afpd, backing to a USB-mounted drive. If I partition the drive on OSX first (hfsplus, no journaling), then mount it under Linux, chmod & chgrp it to the TimeMachine userID, and share with netatalk, then I get the same error you report (after "preparing backup", error is "Setting security information: Operation not permitted"), and backup fails every time.

However, if I stop netatalk, repartition the USB drive to a single EXT4 partition, mkfs.ext4, remount and chmod, chgrp, and share with netatalk, then I do not see this error and TimeMachine backups work fine.

I expect that the problem is userID/permission related, but since ETX4 is working for me, I have not pursued it.

  • Yes. This solution worked for me, both on Yosemite and El Capitan. Thanks.
    – insys
    Commented Feb 9, 2016 at 17:38
  • Thanks a lot. If I know that netatalk works with ext4 I don't even choose hfs+ format. Any restart without properly umount makes the drive read only, and you have to fsck it to make writable again. Commented Aug 29, 2016 at 13:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .