My Macbook does not power up for more than a few seconds, and I have declared it dead. The only issue is that there is still a disk inside of it of Snow Leopard. The MB doesn't power on long enough to push the trackpad button, or do the PRAM Reset, or press the Eject button on the keyboard before shutting down again. Any ideas how to MANUALLY remove the disk?


Get a standard USB mouse, attach it and press and hold the primary mouse button, while starting. This invokes the eject before the blutooth drivers are even loaded.

  • Tried, but it wasn't a bluetooth mouse; it was the built in trackpad – Canadian Luke Aug 9 '11 at 20:08

Kind of a shot in the dark, but one reason a MacBook won't start up at all is that the battery is so dead that it tells the Mac not to run. Some models allow you to still run the computer with the power adapter attached and the battery removed. Have you tried that? If it works, you can keep things running long enough to eject the disk.

You can also (kind of a desperation move) work a thin bit of plastic (thinner than a credit card) around in the slot to try to get it under or on top of the disc and work it back and forth until the disc pops out.

  • Battery was out, PSU was plugged in and was showing Green. It only starts up for about 1-5 seconds, depending on how long I leave it UNPLUGGED for. I know there's something wrong on the motherboard, probably a capacitor or two, but I need a mechanical way to eject the disk – Canadian Luke Aug 9 '11 at 20:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .