3

I tried to update Xcode to 7.0.1 today and it told me that I needed to get OS X 10.10.4 or greater (I had 10.10.3). I agreed to that update, but it didn't update OS X and has now marked XCode as being at 7.0.1 in the App Store. However if I go into XCode it still shows 6.4 and lacks the new features like iOS 9 in the simulator.

So I had it do the OS update to 10.10.5 and let it do the reboot and install process. It came back up and it still shows that XCode is at 6.4 in the application itself, but as updated in the App Store.

What gives? Any idea how to get it to actually update?

  • How many Xcode.app are found from mdfind Xcode.app ? Worst case, you could just delete your Xcode and re-download the 7.0.1 but that would be longer than sussing out if you have two copies mounted at the moment. The MAS will search all connected drives and perhaps you have an Xcode somewhere you didn't expect. – bmike Oct 19 '15 at 19:39
  • I don't have anything attached to this machine. So I don't know where else it would come from other than a virtual drive. But I ran the suggested command and it only spat out one line with Xcode.app on it. – Patrick Oct 19 '15 at 20:15
  • @rubynorails Great link, but I'm going to leave this open for now. the linked question isn't as detailed with specific of the upgrade and this user is asking about Xcode 7 on OS X 10.10 - the linked question can cover 10.11 and Xcode 7 with the link to help people find all the answers. – bmike Oct 19 '15 at 22:06
3

I would do the following:

  • Open Xcode
  • Open Preferences
  • select Locations

If your command line tools and Xcode about box don't both say 7.0.1 (7A1001) then you might want to just delete Xcode using Launchpad and then re-open the App Store to download a clean copy of the app. If you want to purge old simulators and SDK from ~/Library/Developer, do that now as well after making a backup of things just in case.

enter image description here

I had some issues with the beta versions of the app and deleting all traces of the app helped me with some document set download issues - perhaps your simulator issues are related to mixing versions between 6 and 7 too?

  • Removing it from Launchpad does not remove it from the computer. However, I did drag it to the trash can and then emptied the trash. Then I re-installed through the App Store and the problem was resolved. – Patrick Oct 21 '15 at 18:09
  • @pthurmond Yay - I'm glad you're back on track. – bmike Oct 21 '15 at 18:39
0

See my answer to a somewhat-similar question here. I have a feeling that it will solve your specific issue as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .