0

(MacBook Air, mid 2013, new install on wiped drive of OS X 10.11 El Capitan)

According to "Internet Accounts" preferences, I have five active email accounts: iCloud, gmail, yahoo, americtech.net, and Comcast. I thought I had set up Mail.app, but found only two accounts were listed: iCloud and Comcast. When I attempt to add an account (any of the remaining three), I am asked for username and password, then informed that the account is already active. Mail.app has not crashed, just won't accept any other accounts. I have all five running on an iMac (Yosemite) and an iPad.

No apparent way of manually setting up the accounts; I'm thinking of visiting the Genius bar!

1

O.K. I have an update. I had checked the "hand-off" to another Mac in the General preferences. I unchecked it and now have two of the accounts added. Then, finally, I unchecked all the Google items in the Internet Accounts pane, turned off any device with Google anything, logged into Google from the Internet Accounts pane and mirabile dictu! gmail is now in place and downloading messages.

So: 1. Handoff is a nice feature, but it sure can mess up Mail. 2. Gmail is as quirky as many have claimed.

Thanks to bike for his answer.

0

Apple is shifting software questions to online support since you don't need an appointment there. http://support.apple.com

However, you might make a head start on the troubleshooting by making a second user account. Log out of your problematic account and log into the new account.

Set up one mail account only in Internet accounts and open mail. The connection Doctor window will let you see any errors with that one account. If it's green, delete it and move on to the rest of the accounts, one by one.

Then you'll know if the error is settings or one mail server or the computer itself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .