13

I used a crummy AT&T (*coughAT&Tsymbollookslikedeathstarcough*) router to build a private LAN. It has no service/DSL connections, there for it detects no internet access (naturally) and will give me this pop-up on a Mac:

Pop-up on Mac

This, as you can see, seems to be a Safari window of sorts that is sourcing captive.apple.com. Because I have no DSL connection, all DNS resolutions get translated to the router's web host. This means that every 5 to 10 minutes I get this pop-up. The WiFi connection does work, but I get this annoying pop-up that interrupts my work.

On an iPhone, I have a similarish problem, although it is more consequential. In Settings --> Wireless it gives me this same page asking me to Log In. I assume that's the function of captive.apple.com. I know places like McDonalds or Starbucks will do this to make sure you come in and buy something before getting on their WiFi.

My Question is this: How do I disable this on a Mac so that I don't have to worry with this pop-up anymore? The iPhone is a secondary problem, but it would be nice to have a solution for it. Would a /etc/hosts entry fix it, or is it more complicated than that?

OS X version 10.11 El Capitan
2011 Mac Mini

13

There's 3 ways.

  1. sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.captive.control Active -boolean false

  2. Just delete (or rename) /System/Library/CoreServices/Captive Network Assistant.app

  3. Add an entry in /etc/hosts containing 127.0.0.1 captive.apple.com

  • And it should actually be 127.0.0.1 captive.apple.com – Daniel Oct 19 '15 at 1:44
  • And the /etc/hosts entry did not work – Daniel Oct 19 '15 at 1:47
  • The defaults write didn't work – Daniel Oct 19 '15 at 1:48
  • 2
    @Daniel Are you on El Capitan? If so, you'll need to disable System Integrity Protection before messing with the System files. – user24601 Oct 19 '15 at 2:20
  • 1
    Note that this will not address the iPhone at all. – samh Oct 19 '15 at 14:49

You must log in to answer this question.

protected by bmike Sep 14 '16 at 1:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .