3

I always favor MPlayerX as my video player, it works perfectly. However since a few days, when playing fullscreen, it seems to no longer interpolate the video content, resulting in a 'pixelated' output.

If I compare it with QuickTime or VLC for example, using the same video file, with MPlayerX I can see pixel blocks in the output, the typical jagged edges from image stretching, whereas it looks smooth in other players.

I already removed + reinstalled it, no difference. I checked all the settings, couldn't find anything related, I changed 'image enhancement' between None, Normal, and Advanced, no difference.

In case it's relevant: I upgraded to El Capitan earlier this week. Can't tell for sure but this problem started somewhere around the same time. Can it be related, and if yes, is there any El Capitan-specific setting involved that could fix this?

  • I've been having the exact same thing and tried everything I could think of, but with no luck. Even the most HD files still look Pixelated while they never were before. I think you're right with your assumption that is has something to do with de update to El Capitan; that's when this all started with me. I've also noticed that whenever I try to download MplayerX from the App Store, I get an error saying it can't be downloaded. Anyone who could explain this? – user153030 Oct 18 '15 at 16:58
  • Since this might be an issue with a specific version of MPlayerX and OS X - could you edit in the version numbers? That way if someone needs to know what versions are affected, this will help them narrow down the cause... – bmike Oct 18 '15 at 17:46
  • I actually got MPlayerX through homebrew (brew cask install mplayerx) but downloading it from the developer's site made no difference. I never use App Store but I reckon it's the same. Version numbers: OS X El Capitan v10.11 (15A284), and MPlayerX v1.1.0 (1854). – RocketNuts Oct 18 '15 at 19:19
  • 1
    I've got the same issue after upgrading OSX to El Capitan. MPlayerX 1.1.0 (1854) – Dawid Hyży Oct 20 '15 at 13:03
  • I have the same issue after upgrading to OSX El Capitan. – Shamal Karunarathne Oct 20 '15 at 18:48
1

I had the same problem at my both devices, MacBook Air (mid 2011) and 5k Retina iMac (mid 2014) only after upgrading to El Capitan. I tried everything to solve the issue with MPlayerX (as it's my fav player and most used app) but no luck. Later i downgraded my MacBook Air to Yosemite and problem was solved. Now I don't think it's a OS X related problem because other players are running smoothly so I guess it's high time for MPlayerX to release a new version.

0

I've had the same issue since the first El Capitan betas. I wrote to the developer and he said a fix is coming with the next version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .