2

I have a 76GB encrypted sparse bundle on the rMBP SSD drive. Mounting it by double clicking it in Finder was pretty much immediate in Yosemite.

With El Capitan a popup appears with "Verifying 'name of sparse bundle'" and a progress bar. The progress bar shows no progress and after fifteen minutes or so the popup disappears and the password entry dialog box appears. After the password has been entered the sparse bundle is finally mounted.

When I run the Disk Utility First Aid function on the mounted volume it finishes in a few seconds and reports no errors. Console does not seem to show any related messages during the mounting.

Is there any reason why this popup appears and is there a way to circumvent it? Fifteen minutes to mount a volume is just not practical.

  • What is in the sparse bundle? if it's a Time Machine destination with multiple hard links, in the verification is going to be slow to matter what OS performs it and the upgrade could be coincidental and not causal... – bmike Oct 18 '15 at 15:03
  • It contains business data that is subject to NDA. No hardlinks. – root Oct 18 '15 at 15:12
  • 1
    Did you previously have image verification switched off? defaults write com.apple.frameworks.diskimages skip-verify -bool YES – Tetsujin Oct 18 '15 at 15:26
  • Not that I know of but I haven't done a fresh install since Leopard so possibly I have and El Cap turned it back on. I do think its unlikely I did though because if this data gets corrupted it would be a major pain. – root Oct 18 '15 at 15:33
  • You don't need to verify the image every time you open it... You can skip it. Just make backups of the disk image, and occasionally verify through Disk Utility. – At0mic Oct 18 '15 at 19:06
1

I also had a sparse bundle that was very slow (>1 minute) to mount, but I solved this (it now mounts in seconds) by turning off automatic file system checking. Before I figured it out, this would happen:

hdiutil attach -verbose ~/the.sparsebundle paused at this line:
Checking volumes…
and it would appear in Activity Monitor as hdiutil using 100% CPU, for over a minute at a time, depending on connection speed.

To speed things up, pass the noautofsck option to hdiutil, like so:
hdiutil -noautofsck ~/the.sparsebundle

Or if you are mounting any other way, set the system preference:
defaults write com.apple.frameworks.diskimages auto-fsck -bool NO

It is possible your update to Sierra resulted in a default being reset and/or a bugfix, per the hdiutil man page:

By default, only quarantined images (e.g. downloaded from the Internet) that have not previously passed fsck are checked.

You could turn off the automatic file system checking and then check the output of diskutil verifyVolume /Volumes/theSparseBundleVolume occasionally, as a balance between data integrity and convenience. Keep in mind, that diskutil command will unmount your volume.

0

After installing Sierra the password popup appears instantaneously. After entering the password the volume is available immediately. So for anyone else with this problem I'd say upgrade to Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .