36

Recently I noticed that on my iMac, running El Capitan, the Open Recent menu has stopped getting updated, both in the Apple menus, and for apps, and both for the Open Recent menu item, and the list that pops up from the Dock.

I checked in System Preferences | General | Recent Items, and it is saying None. I have tried a number of times to reset it to 20, but it shows up as None when I get back in to System Preferences.

I hope someone can help me sort this problem out.

17

For me, this partially fixed things:

  1. Close all open apps.
  2. Move ~/Library/Preferences/com.apple.recentitems.plist (and ~/Library/Preferences/com.apple.recentitems.plist.lockfile if it exists) to a backup directory.
  3. Reboot.

In my case this fixed the recent items lists under the File menu in each app and the Apple menu. But the context menus on Dock icons still do not update.

  • 1
    I wait for update 3 months and nothing. 😬 – BG Bruno Dec 16 '15 at 21:48
  • This should be selected answer, it works great – mattgabor Aug 25 '16 at 20:43
  • 1
    When I did this it worked. What really surprised me was that the Recents appeared right away. The broken .plist wasn't a corrupted cache, it was breaking the display of the Recents. – benc Oct 17 '17 at 18:45
6

I ran into this today on a month-old iMac. The only thing that isn't fresh about it is my account, which has been replicated across 5 machines and 12 major MacOS versions using Migration Assistant when possible, leaving it with a fair bit of cruft in ~/Library/Preferences/. Unfortunately, in recent versions Apple has made it complicated to clean up that directory effectively by trashing files because cfprefsd manages the real preference info and you need to talk nicely to it with the defaults utility.

Anyway, I fond that every time I tried to change the preference I got a sequence of log entries like this:

Jul 14 18:14:03 extravagant sharedfilelistd[411] <Critical>: [default] [<CFString 0x7fff77ea0e00 [0x7fff77f58440]>{contents = "com.apple.LSSharedFileList.RecentApplications"}] List write failed invalid info items: (null) properties: (null)
Jul 14 18:14:03 extravagant sharedfilelistd[411] <Error>: -[ListStore writeListItems:properties:withListIdentifier:notificationHander:] [com.apple.LSSharedFileList.RecentApplications] List write failed invalid info items: (null) properties: (null)
Jul 14 18:14:05 extravagant com.apple.preference.general.remoteservice[85562] <Warning>: Error getting number of recent items of type 2, LSSharedFileListCopyProperty returned NULL
Jul 14 18:14:11 extravagant com.apple.preference.general.remoteservice[85562] <Warning>: New number of recents: 30
Jul 14 18:14:11 extravagant com.apple.preference.general.remoteservice[85562] <Warning>: Error getting number of recent items of type 1, LSSharedFileListCopyProperty returned NULL
Jul 14 18:14:11 extravagant com.apple.preference.general.remoteservice[85562] <Warning>: Error getting number of recent items of type 2, LSSharedFileListCopyProperty returned NULL
Jul 14 18:14:11 extravagant com.apple.preference.general.remoteservice[85562] <Warning>: Error getting number of recent items of type 3, LSSharedFileListCopyProperty returned NULL
Jul 14 18:14:13 extravagant com.apple.xpc.launchd[1] (com.apple.preference.general.remoteservice[85562]) <Notice>: Service exited due to signal: Killed: 9

Also, both defaults domains and a few dozen files in Preferences told me that most applications with a proper defaults domain like com.example.appname also had a defaults domain like com.example.appname.LSSharedFileList which contained lists of recently used files. Except they weren't recently used files at all. None of the *.LSSharedFileList.plist files had changed since my migration from my old Yosemite machine, and neither had com.apple.recentitems.plist. So I cleaned house by running these commands inside ~/Library/Preferences/:

defaults delete com.apple.recentitems
rm com.apple.recentitems.plist*

The defaults command tells cfprefsd to remove all of the settings in that domain, which leaves a 42-byte logically empty .plist file and a 0-byte .plist.lockfile file which the rm command removes.

defaults find LSSharedFileList |grep 'keys in domain .*LSShared'|cut -d"'" -f2 |xargs -L1 defaults delete
rm  *LSSharedFileList.plist*

Less obvious, but essentially the same thing for all defaults domains with LSSharedFileList in their names

find . -name "*.plist" -print0 |xargs -0 -L1 plutil -lint |grep -v ': OK$'|cut -d: -f1|sed 's/.*/"&"/' |xargs rm

Even less obvious, but apparently crucial. This pipeline finds all of the *.plist files in the current directory (which was ~/Library/Preferences/,) checks each one for validity with plutil -lint, parses out the filenames of those that are not "OK", enquotes them to protect from embedded spaces and the like, and removes them all. In my case the invalid *.plist files were all 0-byte antique files for stuff that can't run on El Cap anyway, so I was sure I was not deleting any actual information. YMMV!!

find . -size 42c -name "*plist" -delete

This swept out any *.plist files that were 42-bytes long, the size of a logically empty plist in binary format. I had a few of those hanging around and they might have been causing the complaint from sharedfilelistd.

killall sharedfilelistd

That terminated the instance of sharedfilelistd running under my account. The system restarted a fresh instance automatically. I'm not sure this was needed, but it seemed prudent since I had just wiped out a bunch of information from the preferences subsystem that was related to the old way of doing what sharedfilelistd apparently does in El Cap.

NOTE: Those 7 commands are the abridged version of what I did that made sense and had effects, scattered across 3 hours of poking around and testing and trying to find info on sharedfilelistd to no avail.

It is also worth noting that there's no sudo involved here, because I was in my own ~/Library/Preferences/, manipulating my own preferences realm. The Recent Items menu and hence its settings are user-specific so wherever that setting is stored (never worked that out...) has to be user-specific as well, not something requiring root to fix. There's a prior response that includes an unexplained massive permission/ACL/flag wipe, run with sudo, that didn't even work for the author, and may cause serious systemic harm. This is nothing like that. Also note that it does not require logging out, rebooting, booting in Recovery Mode, or doing anything else likely to be disruptive.

  • On my system, just running killall sharedfilelistd alone seems to do the trick perfectly! (I'm definitely in a different situation though: I don't have an old migrated profile, this problem seems to start happening at random, rebooting makes it go away for a while). – peterflynn Aug 23 '16 at 1:24
  • Worked great when none of the other solutions worked— my recent documents were even restored after running these commands. 👏 – Slipp D. Thompson Oct 28 '16 at 2:14
4

Workaround

For the Recently Used Application list in the Dock, try the following:

  1. Open Finder, File > New Smart Folder
  2. Press + button next to Save
  3. Select "Kind" is "Application"
  4. Press + button Select "Last opened date" is "this week"
  5. Click Save and check "Add to sidebar"

  6. On the sidebar, right click the created Smart Folder and click "Add to Dock"

4

Open recently used items: Choose Apple menu > Recent Items. You see the apps, documents, and servers that you recently used. For some apps, you can also see the documents you recently worked on. To change the number of items you see in the menu, choose Apple menu > System Preferences, click General, then click the “Recent items” pop-up menu and choose a number.

  • 3
    In my case I had Apple menu > System Preferences > General “Recent items” set to 0. Just changed the value and that's it. – Fred K Sep 10 '16 at 13:58
4

The following worked for me!
Tried all of the previous answers, but none worked.
Then I came across a fix described here on Apple Forums:

First round (tried, but did not work for me):

Note: The command below changes ownership and access rights on all files in your home/user directory and may have unexpected (and harmful) side effects.

Open Terminal, and type:

echo $TMPDIR

If (and only if) you see something like /var/folders/8b/mn2vgjs10gs83krfy1fwxwb80000gp/T/ as a result, run

sudo find ~ $TMPDIR.. \
         -exec chflags -h nosappnd,noschg,nosunlnk,nouappnd,nouchg,nouunlnk {} + \
         -exec chown -h $UID {} + -exec chmod +rw {} + \
         -exec chmod -h -N {} + -type d -exec chmod -h +x {} + 2>&-

Second round (this one did work for me):

  • Start up in Recovery mode.
  • In recovery mode, launch terminal (from utilities menu)
  • Type resetpassword and hit enter (no worries)
  • Select your startup volume
  • Select relevant user
  • At the bottom, under Reset Home Directory Permissions and ACLs, click Reset
  • I repeated the last to steps for all users + root
  • Restart your computer

The description on Apple Forums is really clear, so if in doubt, go there. Hopefully it will help others too.

FYI: All my recent items were gone in all apps, in Apple menu the whole menu item was even gone, and changing in System Preferences from none to whatever kept reverting back to none.
I am on a MacBook Air (early 2014), running El Capitan 10.11.3

  • This worked for me but be warned: if you use a file syncing service running this command might trigger your files to be re-uploaded. I use Dropbox and that's what happened to me; >50,000 files started syncing. You may want to do specific folders instead of just home (~). – Chadwick Jun 27 '16 at 20:10
  • 2
    That 'sudo' horror which you say didn't work for you blindly removes every flavor of protection from a significant collection of files and directories. It may open vulnerabilities that one would not normally have. – Bill Cole Jul 15 '16 at 1:15
2

I've had the same thing happen within applications but in my finder recent items my shows multiple duplicates of the same recent item and seems to add one every time I open the app again. I tried to screen shot the recent items but of course if you try to hit shift-command-4 it changes the recent items to "show XXXX in finder" because you have held down the command. The favorites are also gone from the dialog boxes. smh what in the F is going on with Apple's dev and QA department in the last few years?

app recent items

finder recent items

  • I have the exact same issue. Any solutions? – Stefan Arn Nov 2 '15 at 10:10
  • 2
    I filed a radar bug report to apple. Radar Bug #23370920. Let's wait what they answer. – Stefan Arn Nov 3 '15 at 8:24
  • While useful information, this material is not appropriate as an Answer on a Stack Exchange. The idea of SE is a specific Answer to a narrowly-focused Question. This post furthers a discussion but does not directly provide a solution to the Question. And this is a tangent, as the Question is about a setting not sticking in System Presences. The issue here may or may not be directly related. I would suggest posting as your own Question, but coincidentally I already did post the same, Disappearing "Recent Items" menu item. – Basil Bourque Nov 29 '15 at 0:20
  • To help with the screen shot problem, use the Grab app bundled with Mac OS X. Use the Timed Screen feature. – Basil Bourque Nov 29 '15 at 0:22
  • Please do not post "answers" that do not answer the original question. If you have another question, please post it separately. If you have a comment, please post it as a comment. If you just want to rant, make a blog entry. Let's all work together to keep StackExchange clean. Thanks! – Olie May 19 '16 at 14:57
2

The solution is way more simple. Go to System Preferences. General. Recent items: choose between none to 50.

Then restart your computer

  • That should work, but the whole problem is that it is not uncommon to damage your preferences badly enough that it does not work. – Bill Cole Jul 14 '16 at 23:28
0

As a work-around use TinkerTool to set your "Recent Items" to which-ever value you like.

So far it seems to behave as expected…

-3

go to "system preferences" > "general" > "recent items" el capitan reset this to zero for some reason set it to whatever list length you like, and it will start working again

  • 3
    From the question: "I checked in System Preferences | General | Recent Items, and it is saying None. I have tried a number of times to reset it to 20, but it shows up as None when I get back in to System Preferences." – Timothy Mueller-Harder Oct 24 '15 at 17:15
  • Same thing happens to me; I can't change this from "None." – Rick Dec 15 '15 at 9:15

You must log in to answer this question.

protected by Community Mar 10 '17 at 8:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .