I have external hdd that I've connected to my wifi router Keenetic extra. I've enabled CIFS and FTP in router USB settings page. I can see this HDD folders in terminal using ls without a problem, but I have error trying to connect to it via finder.

I've already tried solutions from this question, none of them works for me. It seems very strange to me that two unix systems (os x and the linux on router) should use some windows-origin protocol SMB to share files with each other in the first place, actually, but alright.

I've also read that os x use some proprietary smb implementation, and that could be the source of the problem, but I don't want to bother to install samba manually right now. How to diagnose this error or maybe there is some workarounds?

  • I'd try changing its name to something non-unicode, at least as a test. Just try New Volume, or even NewVolume.
    – Tetsujin
    Commented Oct 18, 2015 at 8:29

1 Answer 1


I just had this issue from my Ubuntu file server and iMac running El Capitan. The way I solved it is to make sure the samba guest account in Linux has read access to the directory I'm sharing. I did this by adding guest account = foo under the [global] section of /etc/samba/smb.conf and making sure that user foo has read access to the directories I'm sharing. For reference, my share definitions (at the bottom of smb.conf) look like this:

  path = /media/path_to_directory
  browseable = yes
  read only = yes
  guest ok = yes

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .