I don’t know if the upgrade to El Capitan is relevant or not, but lately I’ve noticed I can’t connect to the Internet via public WiFi hotspots with my MacBook Pro.

I can connect to WiFi networks themselves and say, my home WiFi network that requires a WPA password. But now when I connect to public WiFi hotspots I no longer get the modal window that usually asks me to log in using my account with that provider.

Is this a setting or something that may have been disabled in El Capitan? If so, how can I get my Mac to display those modals again? (I don’t even know what they’re called so not sure what search terms to use.)

  • 1
    Does anyone know which application or process is responsible for loading the login dialog and content? – Jason Harrison Feb 23 '17 at 17:50
  • Turning off my Shadowsocks socks5 proxy (I was in China) fixed this issue for me. – Sumesh May 27 '18 at 9:23
  • In case you're having this problem on Catalina, this is the only solution that worked for me: poweruser.blog/… – Lucas Janon Nov 16 '19 at 17:47

11 Answers 11


for me this trick always worked - even on the iphone!

Browse directly to the log in screen: http://captive.apple.com/hotspot-detect.html

  • 2
    Welcome to Ask Different! Please don't give link-only answers. We're looking for answers that provide explanations as to why it answers the question as well as why it's the best answer. Links can change over time and then we'll lose the question-answer context. See How to Answer for info on what makes up a good answer. - From Review - – fsb Jul 6 '16 at 12:13
  • Some more info about Captive Wifi Networks - But your point to have more context to the answer is taken - support.apple.com/en-us/HT204497 – YoYo Jun 28 '17 at 14:04
  • 3
    @fsb I think in this case a link only answer is okay because the solution is to simply navigate to the link. – Tot Zam Oct 16 '18 at 3:01
  • Thanks @TotZam. The answer should be edited to indicate the expected result if the only step is to navigate to the URL. If you would like to do that, and you have the proper reputation, you can do the edit to add that info. – fsb Oct 16 '18 at 12:56
  • This is a great tip to know, thanks for sharing! I'd been on a guest wifi unable to get internet even though I was connected to WiFi. I'd realized when connecting it was no longer popping up the captive portal so I figured that was the problem although I could not find a solution. This worked immediately and taught me something I'm sure I will use and share quite frequently. – TryTryAgain Dec 27 '18 at 15:57

I resolved this issue by removing my custom DNS entries. I prefer to use Google Public DNS and this was disrupting the login screen.

I discovered the issue by running the Network Diagnostics app after experiencing this problem on a recently upgraded MBP Retina (Yosemite -> El Capitan). To run the app, do the following:

  1. Open System Preferences
  2. Choose Network
  3. Click Assist me...
  4. Click Diagnostics...
  5. When the app starts, choose Wi-Fi and Continue
  6. Troubleshoot any issues the app reports (your issues might be different than mine)
  • Changing my DNS to use Google's DNS servers did it for me. – Evan R Sep 11 '16 at 19:52
  • 6
    Yes, this did it for me at the Montréal airport. I was using Google ( DNS and OpenDNS servers. Rather than delete those settings, I chose Sys Prefs > Network > Locations (pop up) > Edit Locations, and clicked the "+" button to create a new Location profile. By default the new settings have no override for DNS. Click the "Apply" button to take effect. All went well. Joined the airport wifi again and the login panel appeared immediately. Later I can switch back to my regular "Location" profile. Thanks! – Basil Bourque Nov 18 '17 at 18:41
  • @BasilBourque you should make that an actual answer. My custom DNS entries were interfering as well. – RubberDuck Dec 10 '19 at 13:01

After searching for hours, this solution worked: Resolving Stubborn Wi-Fi Connection Problems in Mac OS X

To summarize, turn your WiFi off, then move the following files to a folder on your Desktop (for example).





Then reboot, turn your WiFI back on, connect to the network, and the login dialog box should pop up. For me, the second listed above did not exist, so I just moved the other 3. If this works for you, you can delete the files that you moved.

  • this is the only final solution that worked for me: the others had no effect... Thanks man you saved me of 1 hour of hair loss! – numediaweb Jul 21 '19 at 15:27
  • This fixed it for me on MacOs 10.14 Mojave: mkdir wifi && sudo mv /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist ~/wifi && sudo mv /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist ~/wifi – numediaweb Jul 21 '19 at 15:35

My fix was very simple. I removed the hard coded DNS entries I had setup. and which I believe are Google DNS servers. Hope this helps someone.


I had this problem with a fresh install of OS X El Capitan. I had to create a new standard user (not admin) and log in as that to get my public internet login page. Returning to admin subsequently has restored the Wi-Fi like normal. A bug surely.

P.S. Found that workaround at: https://discussions.apple.com/message/29042350#29042350

  • Thanks so much! I’ll give this a try next time I’m out with my MacBook. – Martin Bean Oct 19 '15 at 10:23
  • I tried the above and it hasn't worked. Realised today it's because the user I'd created before was an admin user. It HAS to be a standard user. – user159835 Dec 2 '15 at 8:42
  • Link dead, what did it say, anything about "why"? – rogerdpack Feb 12 '19 at 15:40
  • Yeah, this worked for me on Catalina, really really not ideal but better than nothing - none of the other things worked for me – sdailey Oct 17 '19 at 23:14

I had this exact same problem and after a lot of trial and error this worked for me:-

  1. Go to Network Preferences
  2. Turn Wi-Fi off
  3. Turn Wi-Fi back on
  4. Before the network 'joins' the network manually select it form the Network Name dropdown
  5. For me this finally caused the pop-up to appear

Sounds like voodoo - no idea why this worked, but it did!

  • This was exactly it for me on my 2019 Macbook Pro. – Jason Southwell Jun 13 '19 at 17:45

I had the same problem. I tried every option that has been stated in this section but it still didn't work, then from a different forum someone said try typing www.apple.com and it worked just fine. Not sure if its a long term fix but the pop up login screen did eventually pop up.

Hope this helps

  • typing it into your browser? – rogerdpack Feb 12 '19 at 17:15

I think the modal (login) window is just loading a web page. Most of the time, if you are connected to the wifi network but you still have to login using the modal window, if you type something in the address bar, you get redirected to a login page. This also happens on my phone, but I need to have mobile data turned off, or the browser will load the page using mobile data.

If you do not get redirected for some reason, if you know the address of the page you are supposed to be redirected to, entering this manually sometimes works for me.

If you can manage to get redirected in the browser of your phone, you can simply enter this address on your computer as well. This worked for me just now, I had to copy an address like The url was actually longer, but only this first part was needed. This successfully brought me to the page where I could enter the wifi password. Somehow I had to turn wifi off and on after that (this didn't work before), but I did not have to re-enter the password fortunately.

  1. Remove the Wifi Network
  2. Join it again
  3. When it asks for credentials, make sure to turn off the option to remember the login.

Funny thing is that it does not go through the logon screen doing so, just the modal dialog box is displayed.

Not having looked into the details, I assume that a new logon token needs to be generated, and the remembered logon is just no good.

Another option that seems to work for me is starting up Firefox instead. Either it will come-up with a login screen, or in the banner it will instruct that a logon first might be required (clicking the button/link in the banner will redirect to the logon screen)


I had the same problem even on Sierra when I tried to login to public network. Network "Assist me..." didn't do the work for me. In fact, it reported the network connection was ok. I need to click the "Advanced" in Network settings and DNS tab. Hit the link under Search Domain in browser and the term page eventually showed up.


This blog was helpful when I ran into this issue today.

In particular flushing the DNS cache, then reconnecting WiFi solved it:

sudo killall -HUP mDNSResponder

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .