8

When my new Macbook Air (13" mid-2011, Lion) wakes from sleep (by opening the lid, clicking the mouse or pressing the space bar), it usually wakes to the last application I was using, then changes applications as if I had pressed alt-tab.

  1. Has anyone else observed this phenomenon and
  2. Does anyone know what could be causing it
  • 1. I have never seen this on my 2007 MacBook. 2. Stuck key? – dan8394 Aug 10 '11 at 4:48
  • 1
    Is your clicking or typing (to wake) causing the app to switch? Have you tried developing a habit of waking the Mac with the Shift key, which should have no such effect? Oh yeah, also, simply opening the lid wakes it up so I bet with 95% certainty that your click or keyboard presses are being registered as meaningful input, not waking your MBA! – Jared Updike Aug 12 '11 at 18:20
  • When I resume by opening the lid (no keypress/trackpad), I still get the application switch. – Daniel Aug 15 '11 at 4:09
  • This has sometimes happened to me when closing applications, not when waking the computer from sleep, but I believe that the underlying "problem" is the same. Let me explain. I use Spaces quite a lot, and the understood behavior when closing an app on a certain space is to remain there; however some apps would "steal" the focus and throw me on another space. Last two apps I remember who had this problem were Adium and Sparrow, though now that problem is gone. I don't know if the problem is some specific configuration on the users part, a glitch in the OS or a bug in the app. Sorry for not prov – Marko Nikolovski Aug 21 '11 at 9:21
  • I can't believe this still isn't fixed! Happens on my brand new MBA too. – Emil Aug 18 '12 at 20:59
4

This is related to the System Preference for when it prompts you for a password when it wakes up. Change it to never, and it goes away (less secure) or always (more secure, but a PITA). Here's the link that helped me:

https://discussions.apple.com/thread/3268136?start=0&tstart=0

  • Awesome! This does seem to be the problem. I don't care for the solution, but it does work. – Daniel Jul 5 '12 at 23:45
  • Bah. The problem seems to be back (less frequent, but still present) despite this fix. – Daniel Dec 31 '12 at 7:27
2

Repair your disk permission.

Reboot your system then press the ALT key. Select the Recovery partition and then use Disk Utility to repair permission.

I think permissions repair better when you're not using the volume that you're mounted on.

  • FWIW, it's been doing this since day one when I first booted it in factory condition, but I'll give it a try. – Daniel Sep 18 '11 at 23:34
  • Didn't work. :-( – Daniel Sep 22 '11 at 4:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .