I have the prerelease version of Apple's "The Swift Programming Language" book. No matter what I try, Apple won't let me update it to the release version. Has anybody else encountered this problem, and better yet, solved it?

  • ...and what have you tried? – Tetsujin Oct 17 '15 at 15:17
  • I've tried looking to see if an update is available. I've tried deleting my current copy of the book and re-downloading it. – Duncan C Oct 17 '15 at 15:33

This is the release version: https://itunes.apple.com/us/book/swift-programming-language/id881256329?isInPurchasedView=true&mt=11

This is the prerelease version: https://itunes.apple.com/us/book/swift-programming-language/id1002622538?isInPurchasedView=true&mt=11

  • This is really frustrating. When I click on your link to the release version it opens my release Swift 1.2 book. I just deleted that and am re-downloading it to see if that gives me the release Swift 2.0 version or not. – Duncan C Oct 17 '15 at 19:36
  • It appears that THAT gives me the release Swift 2.0 book. – Duncan C Oct 17 '15 at 19:36

Ok, I finally got the Swift 2.0 book.

If I clicked the link that @IronCraftMan posted, above, it would open my copy of the Swift 1.2 version. I had to delete the release version and then re-download it and then finally I see the new version. However, the cover art does not say anything about Swift 2, although the link from IronCraftMan shows a cover that says "Swift 2.0 edition."

What a confusing mess.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .