Whenever I try to boot Arch, Mint or Debian Linux from a USB stick using GRUB 2 on my Mac with compatibility mode, it freezes on this error (given in the question title).

I've tried every available, up to date, method on the web.

Any help is appreciated.

I have managed to get into the GRUB 2 commandline. Is there an option to set or something else?

  • Why do you need grub on mac ? You can easily choose a startup disk by hitting alt + option when the mac is starting. Check : github.com/SevenBits/Mac-Linux-USB-Loader this tool is easy to use and makes good usb linux for mac.
    – enzo
    Commented Oct 16, 2015 at 17:09
  • Well, I just downloaded the Linux Mint ISO file and burned it to the flash drive - GRUB 2 is what comes up with the boot options after I boot from the EFI menu. Thanks for the link - I have seen it before but cannot use it as my OSX bluescreens on boot, even before the "ALT+R" gets a chance. Commented Oct 16, 2015 at 17:16

4 Answers 4


There seems to be a problem with the radeon driver when booting. You can test a fix by doing this:

  1. When you see the grub menu, press 'e', which will allow you to edit the entry.
  2. Go to the line with "linux...." and look for where it says 'ro'.
  3. After the 'ro', add 'nomodeset' (without quotes), and then boot (press F10).

If that works, you can make it permanent by editing your /etc/default/grub file, and changing the line to look like this:


Then run:

sudo update-grub

This isn't the best solution, since it seems to put your machine into software rendering. I'm hunting for a proper fix.

  • 1
    life saver!! thanks mate. Let me know if you find a proper fix
    – doz87
    Commented Aug 17, 2016 at 2:52
  • Had the same problem with OpenSUSE on non-mac hardware, this also worked for me except that instead of update-grub I had to run grub2-mkconfig -o /boot/grub2/grub.cfg Commented Dec 21, 2016 at 4:40

Once in GRUB press the e key. We’re now going to disable the AMD graphics card while we boot into the Ubuntu Live CD. Look for the line set gfxpayload=keep. Once you’ve found it, type the following lines underneath to disable the AMD graphics card:

outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0

Next find the kernel line and after “quiet splash” , add the following

i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0

Source: https://orville.thebennettproject.com/articles/installing-ubuntu-14-04-lts-on-a-2011-macbook-pro/

  • Perfect. That got me booting with a Xenial USB stick - thanks!
    – cdegroot
    Commented Dec 16, 2017 at 3:07

If you have a graphics card in pull it out and use the integrated graphics controller. If you dont have an integrated one try another card.

  • Bit tricky if you've got it soldered in :P
    – JMY1000
    Commented Feb 1, 2018 at 6:47

My build is printing the message: fb0: inteldrmfb switching from efi vga

My workaround is to add video=simplefb:off after quiet splash kernel parameter and hit f10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .