10

Since El Capitan (10.11) I have problems with draining battery. So I searched through forums and didn't find right answer, but they gave command which show logs.

So this is the log.

<Notice>: Wake reason: EC.SleepTimer XHC1 (SleepTimer)
<Notice>: Wake reason: (HibernateError)
<Notice>: Wake reason: EC.SleepTimer XHC1 (SleepTimer)
<Notice>: Wake reason: (HibernateError)
<Notice>: Wake reason: EC.SleepTimer XHC1 (SleepTimer)
<Notice>: Wake reason: (HibernateError)
<Notice>: Wake reason: EC.LidOpen XHC1 (User)

The last one is OK, since I really did open the lid. But those above shouldn't happen.

And the result of grep -i wake /var/log/system.log command:

Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: Wake reason: EC.SleepTimer (SleepTimer)
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleCamIn::wakeEventHandlerThread
Oct 17 02:39:56 MBP-Tomasz-2 PowerChime[337]: 141453.711174: EARLY WAKE: kStateAsleep -> kStateEarlyWake
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleThunderboltNHIType2::prePCIWake - power up complete - took 64409 us
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleThunderboltGenericHAL::earlyWake - complete - took 1 milliseconds
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: ARPT: 27059.087764: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: ARPT: 27059.088510: IOPMPowerSource Information: onWake,  SleepType: Deep Idle,  'ExternalConnected': No, 'TimeRemaining': 7974, 
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 02:39:56 MBP-Tomasz-2 kernel[0]: AppleCamIn::wakeEventHandlerThread
Oct 17 02:39:56 MBP-Tomasz-2 PowerChime[337]: 141454.445396: DARK WAKE: kStateEarlyWake -> kStateDarkWake
Oct 17 02:39:56 MacBook-Pro-Tomasz-2 PowerChime[337]: 141454.462163: GOING TO SLEEP: kStateDarkWake -> kStateAsleep
Oct 17 02:39:55 MacBook-Pro-Tomasz-2 ntpd[232]: wake time set -2.385026 s
Oct 17 02:39:57 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::handleWakeEvent_gated
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: Wake reason: EC.LidOpen (User)
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: vm_compressor_fastwake_warmup (6201 - 10125) - starting
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000320
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::wakeEventHandlerThread
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleThunderboltNHIType2::prePCIWake - power up complete - took 172 us
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 kernel[0]: AppleThunderboltGenericHAL::earlyWake - complete - took 1 milliseconds
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 PowerChime[337]: 168887.170875: EARLY WAKE: kStateAsleep -> kStateEarlyWake
Oct 17 10:17:09 MacBook-Pro-Tomasz-2 WindowServer[193]: CGXDisplayDidWakeNotification [27075365873210]: posting kCGSDisplayDidWake
Oct 17 10:17:10 MacBook-Pro-Tomasz-2 kernel[0]: ARPT: 27075.858912: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
Oct 17 10:17:10 MacBook-Pro-Tomasz-2 kernel[0]: ARPT: 27075.858945: IOPMPowerSource Information: onWake,  SleepType: Standby,  'ExternalConnected': No, 'TimeRemaining': 901, 
Oct 17 10:17:10 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000340
Oct 17 10:17:10 MacBook-Pro-Tomasz-2 kernel[0]: AppleCamIn::wakeEventHandlerThread
Oct 17 10:17:14 MBP-Tomasz-2 kernel[0]: AppleCamIn::handleWakeEvent_gated
Oct 17 10:17:15 MBP-Tomasz-2 PowerChime[337]: 168893.051751: FULL WAKE: kStateEarlyWake -> kStateAwake
Oct 17 10:17:15 MBP-Tomasz-2 PowerChime[337]: 168893.051830: Calling fullWakeBlock
Oct 17 10:17:15 MBP-Tomasz-2 PowerChime[337]: 168893.051891: handleFullWake ENTERED
Oct 17 10:17:15 MBP-Tomasz-2 kernel[0]: AppleCamIn::systemWakeCall - messageType = 0xE0000300
Oct 17 10:17:15 MBP-Tomasz-2 sharingd[293]: 10:17:15.363 : Starting AirDrop server for user 501 on wake
Oct 17 10:17:14 MBP-Tomasz-2 ntpd[232]: wake time set -1.061934 s
Oct 17 10:17:16 MBP-Tomasz-2 kernel[0]: vm_compressor_fastwake_warmup completed - took 9003 msecs

So is there a fix for that?

  • 2
    Try the Terminal.app command pmset -g sched. This will list any scheduled wake, sleep, or power events. It is unlikely any are scheduled but worth checking. – Graham Miln Oct 16 '15 at 8:42
  • 1
    @GrahamMiln Yep, nothing scheduled, so it's not a problem. I filed a bug on bugreport.apple.com and I'm waiting for a response. If they will say something interesting I will put it here. – Tomasz Kasperek Oct 16 '15 at 12:41
  • @GrahamMiln I don't get my power nap wakes listed on 10.11 when I ask for the sched. – bmike Oct 16 '15 at 17:49
  • 2
    Could you edit this to show the command you ran to get those logs? It looks to be missing times and also your system log should have lots of hits for "wake" if you check. grep -i wake /var/log/system.log – bmike Oct 16 '15 at 17:50
  • @bmike added the result of command you gave me. It's from last night, only those at 02AM shouldn't happen – Tomasz Kasperek Oct 17 '15 at 8:40
6

Go to energy saver preferences and disable Power Nap for both Battery and Power Adapter. Also, consider disabling wake for network access if you have that enabled.

That's the main cause of periodic wake events. You could have some off USB connection glitch that's waking things, but start with power nap and then eliminate connected USB devices one by one.

Lastly, in Bluetooth preferences, you might choose to not let bluetooth devices wake your Mac in the Advanced settings (button in the bottom right of the preference pane).

There's nothing wrong with those wakes as I see it - how long is the machine awake each interval? 10-15 seconds or 10-15 minutes?

  • It might not be a problem, but It drains my battery and auto waking is my best bet on what could cause the problem. I turned off bluetooth waking devices, lets see, it might help. – Tomasz Kasperek Oct 17 '15 at 8:37
  • 2
    Turning off Bluetooth devices waking computer woeked – Tomasz Kasperek Oct 20 '15 at 9:52
2

What worked for me (issue with battery drain after sleep):

Settings & Prefs -> Energy Saver -> Power Adapter , Uncheck Wake for Ethernet network access

Settings & Prefs -> Bluetooth , Turn off

Device: El Capitan - Mid 2010 15" I don't have power nap on this model

My logs were showing the following before:

<Notice>: Wake reason: EHC2
<Notice>: Wake reason: EC LID0
<Notice>: Wake reason: PWRB (User)
<Notice>: Wake reason: EC LID0
<Notice>: Wake reason: EC LID0
<Notice>: Wake reason: EHC2
<Notice>: Wake reason: EC LID0
<Notice>: Wake reason: EC LID0
<Notice>: Wake reason: PWRB EC LID0 (User)
<Notice>: Wake reason: EC LID0 EHC2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .