0

I have a late 2012 iMac running El Capitan which has become quite sluggish. I’ve tried a few software solutions, but I think it’s something wrong with the disk. (A lot of stuff is fine; anything that touches the disk starts crawling.)

I tried to run the Apple Hardware Test using Apple’s instructions.

I booted my Mac while holding down the D key. I got the “Starting Internet Recovery” screen, then I was asked to select and authenticate with a Wi-Fi network. I did that, and it went back to the “Starting Internet Recovery” screen. Shortly afterward, it got stuck on an error:

enter image description here

apple.com/support

–501 0D

I’ve tried Googling this code, but I can’t find anything on what it means – mostly just some Apple Discussion Forums with other people asking about it.

Anybody here know the answer?

  • Run the commands given in Linc Davis' answer at discussions.apple.com/thread/5679776 & add the info to your question. [Also - heed all his warnings] – Tetsujin Oct 16 '15 at 8:11
  • @Tetsujin Thanks for the speedy response. The machine won't finish booting before I have to leave for work (probably a red flag in and of itself), but I'll try those commands later. – alexwlchan Oct 16 '15 at 8:15
  • @Tetsujin Yeah, so I probably won’t run those commands after all. I set it booting into Safe Mode when I went to work 3 hours ago; stuck at the login screen. I think I’ll have to wipe and start afresh. :-/ – alexwlchan Oct 16 '15 at 11:34
1

Brief follow-up note: it turns out this Mac did have hardware problems.

I took it to the Apple Store a few days after writing the original post, and their more thorough diagnostics discovered a problem with the disk (specifically, the hard drive portion of the Fusion Drive). I got the hard drive replaced under warranty, and after a year I haven‘t seen the symptoms again – I assume this was just an artefact of a failing disk.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .