7

I downloaded OS Font Tools, release 4 beta 1 (osxfonttools.dmg) and try to install in Macbook Pro El Capitan, but installation failed:

enter image description here

enter image description here

anyone knows the reason?

6

Here is how I did it. Get it downloaded from apple (here: https://developer.apple.com/downloads/?q=font ) and run these.

pkgutil --expand OS\ X\ Font\ Tools.pkg tmp
cd tmp
cd fontTools.pkg
mv Payload Payload.gz
gunzip Payload
tar -xvf Payload

Apologies if I forgot any parts but that is basically it.

  • 1
    Worked for me. Came from stackoverflow.com/a/8314197/129202 . Could successfully use ftxdumperfuser later. Just a gotcha: the unpacked files are within the fontTools.pkg folder, which "needs" to be unpacked first or we can't see the contents on Finder. Anyone ending up here probably gets it anyway. – Jonny Apr 14 '16 at 7:40
4

@xaphod's answer wasn't quite comprehensive, so I wrote down all the commands I used to get this working. Here is how I got it working for the next person who needs it (also in a gist if you're into that):

Mount the font tools dmg as a volume on your Mac

hdiutil attach ~/Downloads/osxfonttools.dmg

Navigate into the volume and copy the main .pkg file somewhere locally so you can manipulate it

cd /Volumes/OS\ X\ Font\ Tools/
pkgutil --expand OS\ X\ Font\ Tools.pkg ~/fontTools && cd ~/fontTools

If you ls, here's what's in the file

Distribution      fontTools.pkg     keyboardTools.pkg
Resources         fonttoolbox.pkg

We'll be going into the fontTools.pkg first, and then going into the fontToolbox.pkg

The fontTools.pkg includes the actual executables that we want to use to manipulate fonts navigate into the directory and use gunzip + tar to get at the files

cd fontTools.pkg 
mv Payload Payload.gz && gunzip Payload && tar -xvf Payload

If that command succeeded, you'll see the following output:

x .
x ./._.DS_Store
x ./ftxanalyzer
x ./ftxdiff
x ./ftxdumperfuser
x ./ftxdumpfond
x ./ftxenhancer
x ./ftxfissioner
x ./ftxfusefond
x ./ftxglyphadder
x ./ftxinstalledfonts
x ./ftxmakettc
x ./ftxruler
x ./ftxsplitter
x ./ftxstamper
x ./ftxsummarizer
x ./ftxvalidator

Additionally, all of those ftx* files will be in the current directory.

Move the executables to your local/bin so that they're in your bash path

mv ftx* /usr/local/bin

At this point, you can successfully call any of the executables in your bash path, but they'll fail because they rely on FontToolbox.framework to be in /Library/Frameworks

Navigate into the fonttoolbox.pkg directory and get at the payload like we did earlier

cd ../fonttoolbox.pkg
mv Payload Payload.gz && gunzip Payload && tar -xvf Payload

This outputs a FontToolbox.framework folder in that directory. Move that framework to the appropriate folder in /Library. You need to sudo this command because of restrictions on the system level /Library folder

sudo mv FontToolbox.framework /Library/Frameworks/FontToolbox.framework

If you want a more comprehensive start-to-finish guide, I wrote a blog post about this on medium.

2

This is extremely annoying. The font tools are only available as Release 4, beta 1, and nothing has changed since 2011-10-11. And now, on top of that, the installer fails on OS X 10.11 El Capitan.

The reason why the font tools can no longer install on El Capitan is most probably the new System Inegrety Protection (SIP). Among other things, it prevents certain critical System directories from being modified. The current font tool beta 1 release predating El Capitan by many years, it does not take the SIP into account. Instead, it tries to install the font tools into /usr/bin, one of the directories protected under the SIP. This will fail.

Updating from a system where the font tools had been installed

If you are lucky, you have upgraded from a system where you had the font tools previously installed. In that case, they are not gone. More importantly, the still appear to work all right. They only have been moved by the Capitan installer to the following directory (where {UUID} is a some code):

/Library/SystemMigration/History/Migration-{UUID}/QuarantineRoot/usr/bin

This means you can copy them from there to an executables directory, e.g. /usr/local/bin/. Alternatively, you can use them in-place by adding their directory to your PATH variable. You can achieve this by issuing the following command in Terminal.app (it will add a line to your ~/.profile file):

echo export PATH=\$PATH:`echo /Library/SystemMigration/History/Migration-*/QuarantineRoot/usr/bin` >> ~/.profile

Other things you might try

There are some other thing you might try. Disclaimer: I have not tried any of these:

  1. If you have time machine backups of a system where the font tools were installed, you may copy the font tool executables from /usr/bin to an executables folder on El Capitan, e.g. to /usr/local/bin. You especially want to move the font tool executables that begin with ftx.

  2. You can unpack the OS X Font Tools.pkg file and install the font tools manually, see How to unpack and pack pkg file? or Unpacking an OS X pkg file.

  3. You might be able to install the font tools after disabling the SIP. This can be achieved by following the procedure outlined e.g. in How to Disable System Integrity Protection (rootless) in OS X El Capitan.

    When the SIP is disabled, a modification of /usr/bin should be possible again. Hopefully, there is nothing else that prevents a successfull installation of the font tools.

    Afterwards, it seems like a good idea to turn the SIP back on. I do not know what happens to the font tool executables that have been added to /usr/bin when turning the SIP back on. I guess they might be moved to another quarantine directory. In that case, you can follow the same procedure outlined in the previous section (Updating from a system where the font tools had been installed).

    If turning the SIP back on completely eliminates the font tool executables from /usr/bin without making any quarantine backups, you may copy to executables to another location such as /usr/local/bin before turning the SIP back on.

0

This problem has been fixed in the Font Tools for Xcode 8 beta, released on 2016-06-13. The release installs just fine. The release notes explicitly affirm that installation is now possible:

This package will install command line utilities, Font Tools framework, Blinker, Font Proofer X, FTXViewer, Kerx Tester, MorxTester and UniCharter. These tools support running on OS X 10.11

The current release is Font Tools for Xcode 8 beta 4, released on 2016-08-01.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .