0

On upgrading to Lion, I noticed that cursor movement in emacs (^-N, ^-P and so on) while running in Terminal has become sluggish. Cursor movement in vi seems fine and cursor movement in Emacs.app seems fine too.

Any ideas what is going on?

2

Are you using a translucent terminal window appearance? Terminal now supports window background blur in addition to translucency, and existing settings profiles default to 20% blur (except Pro, which uses 0%). If you have a large terminal window and/or slower hardware, you may notice some slow down when moving around in emacs (compared to vim, emacs is noticeably inefficient about updating the display when moving the cursor around and redraws a lot, which requires redrawing the background).

Try selecting a different profile or edit the profile to disable blur:

Terminal > Preferences > Settings > [profile] > Window > Background > Color

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .